Bug 24186 - Cannot View Help in openSUSE 13.1
Summary: Cannot View Help in openSUSE 13.1
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Documentation ()
Version: unspecified
Hardware: PC Linux
: Low normal
Target Milestone: Future Cycle (TBD)
Assignee: Jérémie Laval
URL:
Depends on:
Blocks:
 
Reported: 2014-10-31 06:51 UTC by Gregory Hatt
Modified: 2017-09-06 09:28 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Gregory Hatt 2014-10-31 06:51:20 UTC
Can not view Monodevelop help in freshly installed / updated openSUSE 13.1. 

After this error clears, a new window appears stating: 

You need a newer monodoc to use it externally from monodevelop. Using the integrated help viewer now. 

Although the newest version of monodoc is installed.

Could not start monodoc : System.ComponentModel.Win32Exception: ApplicationName='monodoc', CommandLine='--help', CurrentDirectory='', Native error= Cannot find the specified file
  at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00352] in /home/abuild/rpmbuild/BUILD/mono-3.0.6/mcs/class/System/System.Diagnostics/Process.cs:1103 
  at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00096] in /home/abuild/rpmbuild/BUILD/mono-3.0.6/mcs/class/System/System.Diagnostics/Process.cs:1167 
  at System.Diagnostics.Process.Start () [0x0002c] in /home/abuild/rpmbuild/BUILD/mono-3.0.6/mcs/class/System/System.Diagnostics/Process.cs:1177 
  at MonoDevelop.Core.Execution.ProcessWrapper.Start () [0x00007] in /home/abuild/rpmbuild/BUILD/monodevelop-3.0.6/src/core/MonoDevelop.Core/MonoDevelop.Core.Execution/ProcessWrapper.cs:27 
  at (wrapper remoting-invoke-with-check) MonoDevelop.Core.Execution.ProcessWrapper:Start ()
  at MonoDevelop.Core.Execution.ProcessService.StartProcess (System.Diagnostics.ProcessStartInfo startInfo, MonoDevelop.Core.Execution.ProcessEventHandler outputStreamChanged, MonoDevelop.Core.Execution.ProcessEventHandler errorStreamChanged, System.EventHandler exited) [0x000c8] in /home/abuild/rpmbuild/BUILD/monodevelop-3.0.6/src/core/MonoDevelop.Core/MonoDevelop.Core.Execution/ProcessService.cs:163 
  at MonoDevelop.Core.Execution.ProcessService.StartProcess (System.String command, System.String arguments, System.String workingDirectory, MonoDevelop.Core.Execution.ProcessEventHandler outputStreamChanged, MonoDevelop.Core.Execution.ProcessEventHandler errorStreamChanged, System.EventHandler exited, Boolean redirectStandardInput) [0x00001] in /home/abuild/rpmbuild/BUILD/monodevelop-3.0.6/src/core/MonoDevelop.Core/MonoDevelop.Core.Execution/ProcessService.cs:116 
  at MonoDevelop.Core.Execution.ProcessService.StartProcess (System.String command, System.String arguments, System.String workingDirectory, System.IO.TextWriter outWriter, System.IO.TextWriter errorWriter, System.EventHandler exited, Boolean redirectStandardInput) [0x00011] in /home/abuild/rpmbuild/BUILD/monodevelop-3.0.6/src/core/MonoDevelop.Core/MonoDevelop.Core.Execution/ProcessService.cs:106 
  at MonoDevelop.Ide.HelpOperations.CheckExternalMonodoc () [0x0004d] in /home/abuild/rpmbuild/BUILD/monodevelop-3.0.6/src/core/MonoDevelop.Ide/MonoDevelop.Ide/HelpOperations.cs:94
Comment 1 Lluis Sanchez 2017-09-06 09:28:24 UTC
This is an old bug report. Please try a more recent MonoDevelop build. If it still happens, feel free to reopen the bug.