Bug 2402 - Unable to push to device - MD
Summary: Unable to push to device - MD
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 5.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
: 2439 2468 2568 ()
Depends on:
Reported: 2011-12-07 19:32 UTC by Ian
Modified: 2011-12-21 01:53 UTC (History)
8 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ian 2011-12-07 19:32:59 UTC
Installation UUID: 438ac2b5-07c9-45e7-a8ce-eac5ad86371d
	Mono 2.10.7 (tarball Mon Dec  5 20:41:19 EST 2011)
	GTK 2.24.8
	GTK# (
Apple Developer Tools:
	 Xcode 4.2.1 (834)
	 Build 4D502
Monotouch: 5.1.1

Please ensure your device is connected...
Connected to: Personal.RunaAli.iPhone4s
Initializing file service...
Uploading application
Finalizing file service...
error MT0000: Unexpected error - Please fill a bug report at http://bugzilla.xamarin.com
System.Exception: AMDeviceStartService returned: 0xe800002d
at MonoTouch.Installation.Device.StartService (MonoTouch.CoreFoundation.CFString) <0x000a7>
at MonoTouch.Installation.InstallationProxyService..ctor (MonoTouch.Installation.Device) <0x0003f>
at MonoTouch.Installation.Installer.InstallApplication (MonoTouch.Installation.Device,string) <0x00027>
at MonoTouch.Installation.Installer/<InstallApplication>c__AnonStorey4.<>m__3 (MonoTouch.Installation.Device) <0x0002f>
at MonoTouch.Installation.Installer/<ExecuteWithSession>c__AnonStorey3.<>m__2 (object,System.EventArgs) <0x000ef>
at MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0006e>
at (wrapper native-to-managed) MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0003f>
at (wrapper managed-to-native) MonoTouch.CoreFoundation.CFRunLoop.CFRunLoopRun () <0x00003>
at MonoTouch.CoreFoundation.CFRunLoop.Run () <0x0000b>
at MonoTouch.Installation.Installer.ExecuteWithSession (MonoTouch.Installation.Installer/Executor) <0x000d7>
at MonoTouch.Installation.Installer.InstallApplication (string) <0x0006b>
at MTouch.Main2 (string[]) <0x03a57>
at MTouch.Main (string[]) <0x0001f>

The application was terminated by a signal: SIGHUP
Comment 1 Rolf Bjarne Kvinge [MSFT] 2011-12-07 19:40:15 UTC
I fixed it this morning, and it'll be fixed in the next beta (5.1.2). For now there is no workaround (besides installing an older MT version).
Comment 2 Rolf Bjarne Kvinge [MSFT] 2011-12-09 08:54:49 UTC
*** Bug 2439 has been marked as a duplicate of this bug. ***
Comment 3 Rob Gibbens 2011-12-10 20:39:18 UTC
I'm also getting this same error.  Hopefully a stable, working build will be available soon.
Comment 4 james.sluiter 2011-12-12 02:26:17 UTC
How can I get 5.1? 
I have already upgraded.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2011-12-12 06:52:55 UTC
James: you can download the latest stable 5.0 release from your account on xamarin.com.

Support can also get you a link to 5.1.0 (or maybe a link to a build from the current master code with the fix).
Comment 6 Rolf Bjarne Kvinge [MSFT] 2011-12-13 07:04:54 UTC
*** Bug 2468 has been marked as a duplicate of this bug. ***
Comment 7 Sebastien Pouliot 2011-12-19 13:23:56 UTC
*** Bug 2568 has been marked as a duplicate of this bug. ***