Bug 23775 - Xamarin Android Player setup failed
Summary: Xamarin Android Player setup failed
Alias: None
Product: Xamarin Android Player
Classification: Xamarin
Component: Player ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-10-13 08:05 UTC by Brad R
Modified: 2014-12-23 13:15 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Brad R 2014-10-13 08:05:58 UTC
When attempting to install the 64bit windows version of the Android player, it fails to install.  It gets passed the VMBox installation, and then dies partway through the Android Player installation.  Here is the logfile:

[1768:138C][2014-10-13T06:47:49]i001: Burn v3.8.1128.0, Windows v6.1 (Build 7601: Service Pack 1), path: C:\Users\brosenbaum\Desktop\Xamarin Android Player x64.exe, cmdline: '-burn.unelevated BurnPipe.{4BF64DA4-D8A9-41EC-A5C2-EA41676CB524} {8D4F4E26-067E-4586-9AEA-0229DEC1D333} 3328'
[1768:138C][2014-10-13T06:47:49]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\BROSEN~1\AppData\Local\Temp\Xamarin_Android_Player_20141013064749.log'
[1768:138C][2014-10-13T06:47:49]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\brosenbaum\Desktop\Xamarin Android Player x64.exe'
[1768:138C][2014-10-13T06:47:50]i000: Setting string variable 'WixBundleName' to value 'Xamarin Android Player'
[1768:138C][2014-10-13T06:47:50]i100: Detect begin, 3 packages
[1768:138C][2014-10-13T06:47:50]i000: Setting string variable 'NETFRAMEWORK45' to value '378758'
[1768:138C][2014-10-13T06:47:50]i052: Condition 'NETFRAMEWORK45 >= 378389' evaluates to true.
[1768:138C][2014-10-13T06:47:50]i101: Detected package: NetFx45Web, state: Present, cached: Complete
[1768:138C][2014-10-13T06:47:50]i101: Detected package: VBoxInstaller_64bits.msi, state: Absent, cached: None
[1768:138C][2014-10-13T06:47:50]i101: Detected package: XamarinAndroidPlayer.msi, state: Absent, cached: None
[1768:138C][2014-10-13T06:47:50]i199: Detect complete, result: 0x0
[1768:1080][2014-10-13T06:47:52]i000: Setting numeric variable 'EulaAcceptCheckbox' to value 1
[1768:138C][2014-10-13T06:47:52]i200: Plan begin, 3 packages, action: Install
[1768:138C][2014-10-13T06:47:52]w321: Skipping dependency registration on package with no dependency providers: NetFx45Web
[1768:138C][2014-10-13T06:47:52]i000: Setting string variable 'WixBundleLog_VBoxInstaller_64bits.msi' to value 'C:\Users\BROSEN~1\AppData\Local\Temp\Xamarin_Android_Player_20141013064749_0_VBoxInstaller_64bits.msi.log'
[1768:138C][2014-10-13T06:47:52]i000: Setting string variable 'WixBundleRollbackLog_XamarinAndroidPlayer.msi' to value 'C:\Users\BROSEN~1\AppData\Local\Temp\Xamarin_Android_Player_20141013064749_1_XamarinAndroidPlayer.msi_rollback.log'
[1768:138C][2014-10-13T06:47:52]i000: Setting string variable 'WixBundleLog_XamarinAndroidPlayer.msi' to value 'C:\Users\BROSEN~1\AppData\Local\Temp\Xamarin_Android_Player_20141013064749_1_XamarinAndroidPlayer.msi.log'
[1768:138C][2014-10-13T06:47:52]i201: Planned package: NetFx45Web, state: Present, default requested: Present, ba requested: Present, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[1768:138C][2014-10-13T06:47:52]i201: Planned package: VBoxInstaller_64bits.msi, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: None, cache: Yes, uncache: No, dependency: Register
[1768:138C][2014-10-13T06:47:52]i201: Planned package: XamarinAndroidPlayer.msi, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: Uninstall, cache: Yes, uncache: No, dependency: Register
[1768:138C][2014-10-13T06:47:52]i299: Plan complete, result: 0x0
[1768:138C][2014-10-13T06:47:52]i300: Apply begin
[0D00:15EC][2014-10-13T06:47:52]i360: Creating a system restore point.
[0D00:15EC][2014-10-13T06:48:10]i361: Created a system restore point.
[0D00:15EC][2014-10-13T06:48:12]i000: Caching bundle from: 'C:\Users\BROSEN~1\AppData\Local\Temp\{5f63cdbe-6d50-4fdf-8efb-add7866fe390}\.be\XamarinAndroidPlayerBundle-amd64.exe' to: 'C:\ProgramData\Package Cache\{5f63cdbe-6d50-4fdf-8efb-add7866fe390}\XamarinAndroidPlayerBundle-amd64.exe'
[0D00:15EC][2014-10-13T06:48:12]i320: Registering bundle dependency provider: {5f63cdbe-6d50-4fdf-8efb-add7866fe390}, version:
[0D00:07B4][2014-10-13T06:48:15]i305: Verified acquired payload: VBoxInstaller_64bits.msi at path: C:\ProgramData\Package Cache\.unverified\VBoxInstaller_64bits.msi, moving to: C:\ProgramData\Package Cache\{5632714F-6A48-4BF2-89E0-F8B6CE9FE6D1}v4.3.10\VBoxInstaller_64bits.msi.
[0D00:07B4][2014-10-13T06:48:16]i305: Verified acquired payload: cab7DD57E98BB21708E574C731CAA7B8524 at path: C:\ProgramData\Package Cache\.unverified\cab7DD57E98BB21708E574C731CAA7B8524, moving to: C:\ProgramData\Package Cache\{5632714F-6A48-4BF2-89E0-F8B6CE9FE6D1}v4.3.10\common.cab.
[0D00:07B4][2014-10-13T06:48:16]i305: Verified acquired payload: XamarinAndroidPlayer.msi at path: C:\ProgramData\Package Cache\.unverified\XamarinAndroidPlayer.msi, moving to: C:\ProgramData\Package Cache\{EFC6F0E7-0E59-452E-84E4-F801048B6D35}v0.0.24\XamarinAndroidPlayer.msi.
[0D00:15EC][2014-10-13T06:48:16]i323: Registering package dependency provider: {5632714F-6A48-4BF2-89E0-F8B6CE9FE6D1}, version: 4.3.10, package: VBoxInstaller_64bits.msi
[0D00:15EC][2014-10-13T06:48:16]i301: Applying execute package: VBoxInstaller_64bits.msi, action: Install, path: C:\ProgramData\Package Cache\{5632714F-6A48-4BF2-89E0-F8B6CE9FE6D1}v4.3.10\VBoxInstaller_64bits.msi, arguments: ' MSIFASTINSTALL="7"'
[1768:138C][2014-10-13T06:52:12]i319: Applied execute package: VBoxInstaller_64bits.msi, result: 0x0, restart: None
[0D00:15EC][2014-10-13T06:52:12]i325: Registering dependency: {5f63cdbe-6d50-4fdf-8efb-add7866fe390} on package provider: {5632714F-6A48-4BF2-89E0-F8B6CE9FE6D1}, package: VBoxInstaller_64bits.msi
[0D00:15EC][2014-10-13T06:52:12]i323: Registering package dependency provider: {EFC6F0E7-0E59-452E-84E4-F801048B6D35}, version: 0.0.24, package: XamarinAndroidPlayer.msi
[0D00:15EC][2014-10-13T06:52:12]i301: Applying execute package: XamarinAndroidPlayer.msi, action: Install, path: C:\ProgramData\Package Cache\{EFC6F0E7-0E59-452E-84E4-F801048B6D35}v0.0.24\XamarinAndroidPlayer.msi, arguments: ' MSIFASTINSTALL="7" ARPSYSTEMCOMPONENT="1" INSTALL_LOCATION=""'
[0D00:15EC][2014-10-13T06:53:35]e000: Error 0x80070643: Failed to install MSI package.
[0D00:15EC][2014-10-13T06:53:35]e000: Error 0x80070643: Failed to execute MSI package.
[1768:138C][2014-10-13T06:53:35]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[1768:138C][2014-10-13T06:53:35]i319: Applied execute package: XamarinAndroidPlayer.msi, result: 0x80070643, restart: None
[1768:138C][2014-10-13T06:53:35]e000: Error 0x80070643: Failed to execute MSI package.
[0D00:15EC][2014-10-13T06:53:35]i318: Skipped rollback of package: XamarinAndroidPlayer.msi, action: Uninstall, already: Absent
[1768:138C][2014-10-13T06:53:35]i319: Applied rollback package: XamarinAndroidPlayer.msi, result: 0x0, restart: None
[0D00:15EC][2014-10-13T06:53:35]i329: Removed package dependency provider: {EFC6F0E7-0E59-452E-84E4-F801048B6D35}, package: XamarinAndroidPlayer.msi
[0D00:15EC][2014-10-13T06:53:35]i351: Removing cached package: XamarinAndroidPlayer.msi, from path: C:\ProgramData\Package Cache\{EFC6F0E7-0E59-452E-84E4-F801048B6D35}v0.0.24\
[0D00:15EC][2014-10-13T06:53:35]i330: Removed bundle dependency provider: {5f63cdbe-6d50-4fdf-8efb-add7866fe390}
[0D00:15EC][2014-10-13T06:53:35]i352: Removing cached bundle: {5f63cdbe-6d50-4fdf-8efb-add7866fe390}, from path: C:\ProgramData\Package Cache\{5f63cdbe-6d50-4fdf-8efb-add7866fe390}\
[1768:138C][2014-10-13T06:53:35]i399: Apply complete, result: 0x80070643, restart: None, ba requested restart:  No

Please let me know if you need more information.
Comment 1 Andrew 2014-10-15 11:56:20 UTC
The same error happens on Windows 8.1 Professional.  

Before install tried:

uninstalling genymotion and virtual box: Failed

removing existing virtual box devices: Failed
Comment 3 Will Schaller 2014-12-17 11:32:26 UTC
Hi, this may be due to the Windows Firewall Service being disabled, as noted by Tetsuro Kato here:  https://bugzilla.xamarin.com/show_bug.cgi?id=24219

Can you try enabling the Firewall service and see if that fixes this issue for you?

Open "Run" dialog box by pressing the Windows logo key + R, type
services.msc, and then press OK button. Find the "Windows Firewall" entry, right click and Start the service. If the Start option is disabled, you may need to go to the service's Properties and change Startup Type to Automatic.

If this does not fix the issue for you, could you navigate to C:\Users\[username]\AppData\Local\Temp and find any log files beginning with Xamarin_Android_Player and post them here? They will give us a lot more information than the usual installation log does.

Comment 4 Brad R 2014-12-17 11:37:46 UTC
Hey Will,

Enabling the windows firewall fixed the issue for me.  Our company disables the firewall by default.  That is a very interesting cause for installation failure, usually it is enabling a firewall that causes issues.

Thanks for the suggestion!  It would be very helpful to have a message if the firewall needs to be enabled, though I will remember it going forward.

Comment 5 Daniele Parisi 2014-12-17 11:40:28 UTC
Also for me enabling the windows firewall fixes the problem.
Thanks for suggestion
Comment 6 Andrew 2014-12-23 13:15:26 UTC
fixed, but will a fix be available for users who choice to disable windows firewall?