Bug 23721 - Copying info in the test output window results in wrong text being copied.
Summary: Copying info in the test output window results in wrong text being copied.
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: unspecified
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Cody Russell
URL:
: 26530 ()
Depends on:
Blocks:
 
Reported: 2014-10-09 15:29 UTC by bryan costanich
Modified: 2017-05-15 23:54 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
picture of the output (391.87 KB, image/png)
2014-10-09 15:29 UTC, bryan costanich
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description bryan costanich 2014-10-09 15:29:55 UTC
Created attachment 8369 [details]
picture of the output

In the attached image, notice the selected error output.

however, when i copy, it gave me this:

  at Xamarin.UITest.iOS.Instruments.WaitForInstruments (Xamarin.UITest.Shared.Processes.RunningProcess instrumentsProcess) [0x00000] in <filename unknown>:0 
  at Xamarin.UITest.iOS.Instruments.StartInstrumentsInternal (System.String targetApplication, iOSRunType runType, System.String deviceId, System.String runLoopPath) [0x00000] in <filename unknown>:0 
  at Xamarin.UITest.iOS.Instruments.StartInstruments (System.String targetApplication, iOSRunType runType, System.String deviceId) [0x00000] in <filename unknown>:0 
  at Xamarin.UITest.iOS.iOSApp.RunAppInEmulator (Xamarin.UITest.Shared.iOS.AppBundle appBundle, Xamarin.UITest.iOS.Instruments instruments, Xamarin.UITest.Shared.Http.HttpClient httpClient, System.String deviceId) [0x00000] in <filename unknown>:0 
  at Xamarin.UITest.iOS.iOSApp..ctor (IiOSAppConfiguration appConfiguration) [0x00000] in <filename unknown>:0 
  at Xamarin.UITest.Configuration.iOSAppConfigurator.StartApp () [0x00000] in <filename unknown>:0 
  at WildFresh.iOS.Tests.Test.StartApp () [0x0001c] in /Users/bryancostanich/bry_code/WildFresh/Source/WildFresh/WildFresh.iOS.Tests/Test.cs:31 
  at WildFresh.iOS.Tests.Test.TestCase () [0x00002] in /Users/bryancostanich/bry_code/WildFresh/Source/WildFresh/WildFresh.iOS.Tests/Test.cs:37 
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00054] in /private/tmp/source-mono-mac-3.10.0-branch/bockbuild-mono-3.10.0-branch/profiles/mono-mac-xamarin/build-root/mono-3.10.0/mcs/class/corlib/System.Reflection/MonoMethod.cs:230 


which, in this case is not terribly helpful
Comment 1 Mike Krüger 2014-10-10 01:08:48 UTC
fixed in 5.7.0.289
Comment 3 Mohit Kheterpal 2014-12-22 11:24:30 UTC
Still looking to connect with Mike to discuss to verifying this issue.
Comment 4 PJ 2015-02-03 15:56:38 UTC
Rob DeRosa is still seeing an issue copying text from the test output pane with XS 5.7.1.14.

"I'm experiencing this issue while trying to debug some UITests for a client. The bug report indicates it was patched in 5.7.0.289 but I am still seeing this behavior in XS alpha 5.7.1 b14.

This specific bug makes it really challenging to pull/copy data from the NUnit Test Output pane (such as paths, exception data, etc). The context menu shows but the 2 enabled options are not clickable. Cmd + C also does not seem to replace clipboard content with the selected text.

Here is a video of my trying to context copy and also Cmd + C copy to no avail.

https://www.dropbox.com/s/yjjp2mf1dzawlbi/cant_copy.mov?dl=0"

REOPENing.
Comment 6 Mike Krüger 2015-02-03 16:37:50 UTC
Sent too early :/

Different bug - the output pane is != test result window. The original bug was about the copy inside the tree view and not the text output window.

It's not that easy to make copy available there. I'll patch something with the focus control. But as said it's a different issue.
Comment 7 Mike Krüger 2015-03-17 11:55:46 UTC
*** Bug 26530 has been marked as a duplicate of this bug. ***
Comment 8 Mike Krüger 2015-03-17 12:21:14 UTC
Seems to work for me:

http://screencast.com/t/gHKI20u2

The bug looks like one of the gtk issues. Reassigning to cody.
Comment 9 Cody Russell 2015-03-17 17:29:57 UTC
It sounds like the issue is that the when the menu opens it's difficult/impossible to click the menu items. This is a long-standing gtk issue on OSX and nobody knows how to fix it. We've been working around it by converting things over to using native menus on OSX.

I tried to convert this over to a native menu today, but the APIs we have for building native menus right now take a CommandEntrySet. Using the edit commands is not having the desired effect (for example, SelectAll is selecting everything in the text editor instead of the test output area).

We're going to need to improve the OSX context menu stuff so we can create menus without using these global commands.
Comment 10 Cody Russell 2015-03-24 11:03:19 UTC
No reason for this to be needinfo, I can confirm it.
Comment 11 Cody Russell 2015-03-30 16:58:29 UTC
Fixed in master 988034c4feaf6222bd340f074032bbfd801072d4
Comment 12 xamarin-release-manager 2015-04-29 06:24:04 UTC
Fixed in version 5.9.0.456 (monodevelop-5.9-branch)
Comment 13 Arpit Jha 2015-07-02 07:38:55 UTC
I have checked this issue and still I am observing the issue with XS  5.9.4 (build 5) as shown in screencast: http://www.screencast.com/t/RctHkQhku

For Now I am Reopening this issue.
Comment 14 Cody Russell 2015-07-02 14:56:24 UTC
I'm not able to reproduce this in either XS 5.9.3 (build 1) or in XS 5.10.0 (git master).

Here's what I'm doing to try to reproduce:

I loaded the MD sources and changed one of the tests so it would break, then ran the tests, then from the test output window I copied the stack trace of the failing test and it pasted into another editor.  It pasted as I expected it to.

I'm not sure what to do with this now.
Comment 15 Arpit Jha 2015-07-03 03:14:47 UTC
I have checked this issue with latest master also .I am still getting same behaviour.

http://www.screencast.com/t/7uTfj1MwQkr4

Environment Info:
=== Xamarin Studio ===

Version 5.10 (build 311)
Installation UUID: 3d25a767-a003-4a7d-9f5e-e57987cf6cf0
Runtime:
	Mono 4.3.0 (explicit/f3e35f2)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 403000347

=== Xamarin.Profiler ===

Version: 0.16.12.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 6.3 (7569)
Build 6D570

=== Xamarin.iOS ===

Version: 8.11.0.1150 (Enterprise Edition)
Hash: 0d7373a
Branch: master
Build date: 2015-06-25 16:12:47-0400

=== Xamarin.Android ===

Version: 5.1.4.16 (Enterprise Edition)
Android SDK: /Users/mac360_xamarin/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: 0.3.7
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.1.0.1160 (Enterprise Edition)

=== Build Information ===

Release ID: 510000311
Git revision: 20ad7be22f58b17e1d9f8ea67afe58aa56a43112
Build date: 2015-07-02 12:29:57-04
Xamarin addins: 1618e0996a5a331aa00d13d9d528f667a3e7912e
Build lane: monodevelop-lion-master

=== Operating System ===

Mac OS X 10.10.0
Darwin mac360-xamarins-Mac-mini.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 16 xamarin-release-manager 2015-07-07 11:06:48 UTC
Fixed in version 5.10.0.326 (master)
Comment 18 Cody Russell 2015-07-07 11:08:15 UTC
gah, I'm sorry. I marked that commit with the wrong bug#
Comment 19 Cody Russell 2015-07-13 14:21:24 UTC
I don't know what to do with this. I tried reproducing this again last week and again today and every time it works as expected.  Here's my build info (git master as of today):

=== Xamarin Studio ===

Version 5.10
Installation UUID: a186f803-5244-4394-9a3a-fe2dbb4de10d
Runtime:
	Mono 4.0.1 ((detached/ed1d3ec Tue May 26 17:22:37 EDT 2015)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400010044

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: 8.10.1.74 (Business Edition)
Hash: 6916d0e
Branch: master
Build date: 2015-06-18 17:18:10-0400

=== Xamarin.Android ===

Version: 5.1.3.1 (Business Edition)
Android SDK: /Users/cody/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

=== Xamarin Android Player ===

Version: 0.3.7
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.1.64 (Business Edition)

=== Build Information ===

55ebdbc9387d8b5ecaefb0688369bea0247e2952
Xamarin addins: 475a9d9460498ad3bec36e8ab469d9d8eb4b0138

=== Operating System ===

Mac OS X 10.10.4
Darwin primrose 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 20 Kirill Osenkov 2017-05-15 23:54:00 UTC
Unfortunately at this point we're resolving this issue as there's likely nothing more we can do about this.