Bug 2370 - MonoDevelop does not save SVN password
Summary: MonoDevelop does not save SVN password
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: 2.8
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Alan McGovern
Depends on:
Reported: 2011-12-06 15:02 UTC by Alexander Riman
Modified: 2012-04-16 09:35 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alexander Riman 2011-12-06 15:02:35 UTC
I'm using SVN without password (I have username and don't have any password).
So, MonoDevelop does not save username and password.
On each restart it asks me again for username and password even if I use "remember" checkbox.
Comment 1 Alan McGovern 2011-12-12 07:57:17 UTC
I just tried to reproduce this issue so I could fix it, but so far I haven't been able to. My steps were:

1) Set up a local svn server where the passwd file for the svn server contains 'bob = '. This sets a username of 'bob' and an empty password.
2) Create a new project in MonoDevelop
3) Publish it to the repository
4) When prompted by MonoDevelop, type in the username and leave password empty and click OK
5) The project publishes to the server correctly.
6) Restart MonoDevelop and attempt to commit. This works without being prompted for a password.

Is there something I've missed, or is there something unique about your setup which might make it impossible to write a username/password to disk?
Comment 2 Alan McGovern 2011-12-14 07:05:58 UTC
After speaking to you on IRC, I still have not been able to reproduce the issue. If it still exists with MonoDevelop 2.8.5, I'm going to need access to a repository which requires a login with no password and also instructions on how to reproduce the issue.
Comment 3 Alexander Riman 2011-12-14 07:19:09 UTC
I have tried MonoDevelop 2.8.5 and have the same issues.
Also, I have tried repository with not empty password. And MD also does not save credentials in this case.
I'm using svn repos with http:// and https:// access.
Comment 4 Alan McGovern 2011-12-14 07:25:12 UTC
I've tested with git svn://, http:// and https:// and had no issues. Let me CC lluis in case he has an ideas on what could possibly cause the issue.
Comment 5 Alan McGovern 2011-12-14 07:25:43 UTC
Ignore the reference to 'git' in the last comment, that shouldn't have been there.
Comment 6 Alan McGovern 2011-12-22 06:36:48 UTC
We still cannot reproduce this issue within the team. Can you try and reproduce the issue with a project created using google code hosting ( http://code.google.com/hosting/createProject ).
Comment 7 Alan McGovern 2012-04-16 09:35:37 UTC
As far as I can tell this issue has been resolved as it could not be reproduced. If a test case can be found where the current code fails, please reopen the issue and I'll investigate again.