Bug 23646 - The 'appearance' property of UITextField does not write correct xml
Summary: The 'appearance' property of UITextField does not write correct xml
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: 5.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Jose Medrano
URL:
Depends on:
Blocks:
 
Reported: 2014-10-06 10:38 UTC by Alan McGovern
Modified: 2014-11-07 05:50 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Alan McGovern 2014-10-06 10:38:09 UTC
If the first option is selected we write 'alert'. If the second value is selected we write '2'. This is not right.

We need to fix this property so it writes the same Xml as Xcode.
Comment 1 Udham Singh 2014-10-06 11:20:46 UTC
I have checked this issue and observed the same behaviour mentioned in bug description. Please refer the screencast : http://www.screencast.com/t/rilOYGsINc

Environment Info : 

=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: ce927b2a-2c07-44c5-b186-09cfdafba6dc
Runtime:
	Mono 3.10.0 ((detached/47db868)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 310000019

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.2.0.193 (Business Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.4
Darwin Xamarin76s-Mac-mini.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Jose Medrano 2014-10-13 04:00:13 UTC
The commit for this fix:
https://github.com/xamarin/md-addins/commit/44448f7e480f32f6d09934141edf40e976c98f14
Comment 3 Alan McGovern 2014-10-13 17:13:12 UTC
merged into master
Comment 4 Mohit Kheterpal 2014-11-07 05:50:30 UTC
I have checked this issue and this issue is working fine as shown in screencast : http://screencast.com/t/yxD3ltDpzb using XS 5.5.4.113
http://screencast.com/t/BsgV8MJs1w using XVS 3.8.113

Hence closing this issue.