Bug 23598 - Creating PCL, then adding Empty Xamarin.Mac project adds invalid XamMac reference
Summary: Creating PCL, then adding Empty Xamarin.Mac project adds invalid XamMac refer...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 5.4
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2014-10-03 15:30 UTC by victor.chelaru
Modified: 2015-05-29 11:10 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description victor.chelaru 2014-10-03 15:30:50 UTC
If Xamarin.Mac project is added to solution with PCL, XamMac .dll is referenced with a red X which displays "Assembly not found for framework Mono / .NET 4.5".

Steps to Reproduce:

1)  File > New Solution...
2)  Select C# > Portable Library
3)  Enter any name for the project and click OK
4)  Right-click on solution and select Add > Add New Project...
5)  Select C# > Mac > Classic API > Empty Xamarin.Mac Project
6)  Enter any name for the project and click OK
7)  Expand the Mac-specific project's references

Actual Results:  
XamMac reference has a red circle with an X in it indicating some kind of error

Expected Results:
XamMac should be referenced correctly 

Additional Information:
The order of the project creation seems to matter.  If the order is PCL, then Mac then the bug occurs.  If the order is Mac, then PCL then the bug does not occur.

Furthermore, once the bug has occurred, right-clicking on "References" and selecting "Edit References" does not show XamMac under the "All" tab.

Build Date & Platform:
Unsure what build date is referring to, but running Mac OSX 10.9.4
Comment 1 Parmendra Kumar 2014-10-04 06:08:11 UTC
I have checked this issue and I am able to reproduce it. To reproduce it I have followed steps mentioned in the bug description.

Screencast:http://www.screencast.com/t/u6D55wXx6
IDE Log: https://gist.github.com/anonymous/42d6f47f6429b8d912c5

Environment Info:
=== Xamarin Studio ===

Version 5.5 (build 227)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.8.0 ((no/db71bc1)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000013

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.2.0.193 (Business Edition)
Hash: 959c1e4
Branch: 
Build date: 2014-10-03 00:25:37-0400

=== Xamarin.Android ===

Version: 4.18.0 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.13 (Business Edition)

=== Build Information ===

Release ID: 505000227
Git revision: 7b721eeec7a2fa4c4f4de0ecd2aed4dc25edac95
Build date: 2014-10-02 15:53:38-04
Xamarin addins: 99ed56b428b31eba1efaace4d82188d6f334e6ca

=== Operating System ===

Mac OS X 10.9.4
Darwin ShrutiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Chris Hamons 2014-12-05 16:35:28 UTC
I believe this may be a duplicate of 

https://bugzilla.xamarin.com/show_bug.cgi?id=17833
Comment 3 victor.chelaru 2015-05-29 11:05:31 UTC
Is this issue resolved? Still remains "confirmed"