Bug 2357 - Right Click does not activate after Monotouch upgrade
Summary: Right Click does not activate after Monotouch upgrade
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: unspecified
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2011-12-06 03:17 UTC by Amanda
Modified: 2011-12-16 18:49 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Screen shot of context menus working in Monodevelop 2.8.2 (55.51 KB, image/png)
2011-12-15 02:28 UTC, Amanda
Editing layout for Monodevelop 2.8.5 (27.00 KB, application/xml)
2011-12-15 02:29 UTC, Amanda

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Amanda 2011-12-06 03:17:28 UTC
After upgrading to Monotouch 5.0.3 this morning, the right click within the solution does not bring up the appropriate window whether right clicking on a project in the solution window to add, or create a new file, or within a class to be able to drill down into a method, for example
Comment 1 Sebastien Pouliot 2011-12-06 08:48:20 UTC
-> monodevelop (sounds like the gtk bug)
Comment 2 Mikayla Hutchinson [MSFT] 2011-12-06 16:10:58 UTC
Can you please tell us your Mono, GTK+ and MonoDevelop versions, from the MonoDevelop About box?

Is it just the context menu in the solution pad that's not working, or are other context menus also affected? Are you using a mouse/trackpad with a real right-click or are you using control+leftclick?
Comment 3 Amanda 2011-12-07 01:59:22 UTC
Hi Michael

Thanks for your response. None of the context menus are working. In other words,for example,  within a class, right clicking on a method call or an object, normally brings up a conext menu that allows you to go to the Definition of the method or that object, plus other options.

So, to clarify, none of the context menus are working, not in the solution window, or in the code classes. I am using the MacBook pro trackpad with the secondary click (bottom right hand corner ) configured to right click. My right click works outside of the Monodevelop solution in all other scenarios
Comment 4 Amanda 2011-12-08 03:53:02 UTC
Hi Michael

Just want to let you know that I have tried plugging in a real mouse to no avail. The right click works in Finder, for example, right clicking brings up the context menu with options "Open, Show Package Contents, Move to Trash" etc etc. However, in my MonoDevelop solution, right clicking does not bring up any context menu.

So, I have tried right clicking with a real mouse, and with the trackpad with the right click configured to the bottom right hand corner, and also with control+leftclick and none of them work inside the solution. ALL of these methods work outside of the solution in other programs like TextEdit, Finder etc etc
Comment 5 Amanda 2011-12-08 03:56:29 UTC
MonoDevelop About Box:



Mono 2.10.6
GTK 2.24.5
GTK# (

Apple Developer Tools:

Xcode 4.2 (828)
Build 4C199

Monotouch: 5.0.3
Comment 6 Amanda 2011-12-14 02:58:00 UTC

Is there any more info that you need from me? Today I updated to Monodevelop 2.8.5 and Monotouch 5.0.4 (the versions for Mono, GTK and GTK# as above).

Right clicking in the solution still does not activate the context menus.

Comment 7 Mikayla Hutchinson [MSFT] 2011-12-14 22:47:17 UTC
Sorry, I haven't been able to reproduce this problem, and it's difficult to diagnose. I have a few more questions that may help to track it down.

* What version of MacOS are you using?
* Does the context menu in the text editor works?
* Are you using a multi-monitor setup?
* Does the problem happen in all parts of the solution pad, or only when close to the edge of the window/screen?

It may be that this is dependent on the layout of the pads in the MonoDevelop window. Could you please attach the layout settings file from the Library folder in your user directory? It's ~/Library/Preferences/MonoDevelop-2.8/EditingLayout.xml

It's possible that this was introduced in MD 2.8.3 or 2.8.4, could you please confirm this by downloading MonoDevelop 2.8.2 from http://download.xamarin.com/monodevelop/Mac/MonoDevelop-2.8.2.dmg and checking whether it has the same problem? You can open the dmg and double-click MonoDevelop to run it without installing it.

FWIW, as a workaround while we debug this issue, you can use Shift-Fn-F10 to activate the context menu.
Comment 8 Amanda 2011-12-15 02:28:04 UTC
Created attachment 1047 [details]
Screen shot of context menus working in Monodevelop 2.8.2

Screen shot of context menus working in Monodevelop 2.8.2. Attached just for reassurance that right clicking brings up context menu in a previous version of Monodevelop
Comment 9 Amanda 2011-12-15 02:29:54 UTC
Created attachment 1048 [details]
Editing layout for Monodevelop 2.8.5

as requested by Michael
Comment 10 Amanda 2011-12-15 02:43:51 UTC
Hi Michael

The issue is somehow caused by the multi-monitor. I unplugged my second monitor and right clicking brought up the context menu.

Anyway, I can confirm that the issue started with the upgrade after Monodevelop 2.8.2. I followed your instructions and downloaded the Monodevelop 2.8.2 (without installing) - when the solution opened in 2.8.2, the right click works (took screen shot and added it as attachedment). This is while the multi monitor was activated

 I have attached the editing layout for Monodevelop 2.8.5. 

My MACOS version is 10.6.8
Context menu activation as a result of right clicking works in all other applications (i.e. Texteditor, Finder, Safari,etc)

For some reason, my Shift-Fn-F10 is configured to toggle minimizing and maximising all open apps, and doesn't bring up the context menu. 

No matter, in the meantime, I will use Preferences/Key Bindings to configure the options I use the most. In rare cases I will just unplug my second monitor.

I really appreciate your assistance on this issue.

Thanks and REgards

Comment 11 Mikayla Hutchinson [MSFT] 2011-12-15 04:06:03 UTC
Thanks, I'll get hold of another monitor and try to reproduce it. We did have some fixes for context menus being positioned wrongly on multi-monitor systems so it must be something about your particular configuration that we didn't test. What are the resolutions and relative positions of your monitors, which is the primary one (dock and menu), and which one is MD running on?
Comment 12 Amanda 2011-12-15 04:23:03 UTC
Hi Michael

I was too hasty saying that I need to unplug the second monitor, I don't. The context menus work when MD opens up on the second monitor (where it opens up first)

My screen arrangement in SyncMaster is such that the one is above the other. The menu bar is at the top of the second monitor, and the applications are docked at the bottom of the MacBookPro monitor below. When MD opens up it displays on the second monitor (above). The context menus work here. By habit , I slide it down to display on my MacBookPro screen (below), where the context menus don't work.

Thank you so much for helping me with this. I am quite happy to continue like this. Please let me know if there is anything more you need if you want to pursue the issue.

Thanks and Regards

Comment 13 Amanda 2011-12-15 04:32:26 UTC
Hi Michael


MD opens up on the bottom screen, i.e. on the MacBookPro first, not on the second monitor
Comment 14 Jeffrey Stedfast 2011-12-16 18:49:04 UTC