Bug 23435 - XS Shared Projects do not work unless you readd reference
Summary: XS Shared Projects do not work unless you readd reference
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: 5.3
Hardware: PC Windows
: High normal
Target Milestone: 5.5.4
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2014-09-27 13:24 UTC by Joe
Modified: 2014-11-06 00:15 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Joe 2014-09-27 13:24:53 UTC
Create a new Forms Shared project for Android.
Create a new class in the Shared project.
Try to reference the new class in the Android project, and receive a "The type or namespace ... could not be found..." error.

To workaround this, remove the Shared reference from the Android project, then readd it. This only sometimes works too, you may have to try multiple times.
Comment 1 Udham Singh 2014-09-29 07:00:22 UTC
I have checked this issue and observed that we are getting the same error when we try to reference a class that exist in shared project from Android Project.

Screencast : http://www.screencast.com/t/fSjF07rdZAo

Note : I have checked this issue with XS versions 5.4 (build 240) and 5.3 (build 441) and observed the same behavior with both XS versions.

Environment Info :

=== Xamarin Studio ===

Version 5.4 (build 240)
Installation UUID: 312d4e9a-339c-433f-a27b-88ce0777af8f
Runtime:
	Microsoft .NET 4.0.30319.34014
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.25

=== Xamarin.Android ===

Version: 4.16.0 (Enterprise Edition)
Android SDK: D:\SDK\android-sdk
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.0    (API level 11)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_31
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 504000240
Git revision: 01786bc67c7024ec33d327ed27e4416d7a846f4e
Build date: 2014-09-17 11:05:20-04
Xamarin addins: 7cd7dfcd6b7b7b53281508954ec080f1cd153ad3

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 2 Lluis Sanchez 2014-10-27 10:48:28 UTC
Udham, can this please be verified on 5.5? I can't reproduce.
Comment 3 Udham Singh 2014-10-27 13:29:28 UTC
I have checked this issue with XS 5.5.2 (build 0) and still getting the same behaviour with XS 5.5.2 (build 0).

Screencast : http://www.screencast.com/t/M7SXYw0xyG2n

=== Xamarin Studio ===

Version 5.5.2 (build 0)
Installation UUID: 3235da96-1cb2-43d5-a836-234fd96911c2
Runtime:
	Microsoft .NET 4.0.30319.18449
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 4.18.0 (Starter Edition)

=== Build Information ===

Release ID: 505020000
Git revision: a5887be38215a6cdd3f349e102ef82a1c4f950a4
Build date: 2014-10-14 12:21:34-04
Xamarin addins: 069ddd29bb70a42238142eee9bac21a5e4b2f9f9

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 4 Lluis Sanchez 2014-10-28 05:32:04 UTC
I could reproduce now. It is a Windows only issue.
Comment 5 Lluis Sanchez 2014-10-28 14:39:53 UTC
Fixed in 5.7.0.344.
Comment 6 Tajinder Singh 2014-11-06 00:15:15 UTC
Now no error is shown if reference a class that exist in shared project from Android Project. Screencast: http://screencast.com/t/zra9O4E4z

Environment Info:
Xamarin Studio
Version 5.5.4 (build 11)
Installation UUID: 9021cab7-54cb-4099-bb6d-b40439903e85
Runtime:
	Microsoft .NET 4.0.30319.35312
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

Xamarin.Android
Version: 4.20.0 (Business Edition)
Android SDK: E:\android-sdk
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: C:\Program Files\Java\jdk1.7.0_67
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

Build Information
Release ID: 505040011
Git revision: eeee7455222308275e32ba67790c0b42d904292b
Build date: 2014-11-04 17:43:49-05
Xamarin addins: 53c87071a252e02e7bc7a80bf735b9fd4a89339d

Operating System
Windows 6.1.7601.65536 (64-bit)