Bug 23398 - Windows Updater force-restarts Windows
Summary: Windows Updater force-restarts Windows
Status: RESOLVED DUPLICATE of bug 20897
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Updater ()
Version: 5.4
Hardware: PC Windows
: High normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2014-09-26 04:46 UTC by gserg.g
Modified: 2014-09-26 13:14 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 20897

Description gserg.g 2014-09-26 04:46:40 UTC
A worse version of bug 22422 here.

Last several updates of Xamarin Studio cause Windows itself to unexpectedly restart after the update, not just the studio.

I notice the updater does not try to close a running instance of Xamarin Studio from which it was launched (using the Help - Check for updates menu).

When the update finishes, Windows restarts without a warning or confirmation. All running programs are given two seconds to save the data, then they are killed and the data is lost. I have lost data because of this - a program displayed the Do you want to save dialog, and I did not have time to click Yes.


Running Windows 7 SP1 x86.
Happened two times in a row, when installing the most current XS update (5.4 build 240) and the previous stable one.
Each time I had a project loaded in XS when I checked for updates, if that matters.
Comment 1 Lluis Sanchez 2014-09-26 13:14:06 UTC

*** This bug has been marked as a duplicate of bug 20897 ***