Bug 23344 - physical device is not working VS2013
Summary: physical device is not working VS2013
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-09-24 11:29 UTC by Firoz Khan
Modified: 2016-12-22 19:25 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Logs (151.74 KB, application/x-zip-compressed)
2014-09-29 03:16 UTC, Firoz Khan
Log Files (1.20 MB, application/x-zip-compressed)
2014-09-29 03:17 UTC, Firoz Khan

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Firoz Khan 2014-09-24 11:29:35 UTC

I have updated Xamarin with latest updates, but I am facing problem in IOS. I have attached the IOS device to mac but it is not visible in my windows machine VS2013.

Got the mail:

Please type your reply at the top of the email... 
Brendan Zagaeski 
SEP 23, 2014  |  03:54PM EDT
Hi Firoz,

I'll pick up on this case to get a fresh set of eyes on the problem.

From your version information, it looks like you might have gotten stuck on some old versions due to a bug in one of our old installers. Here are some next steps to try:

1. Install the latest Xamarin for VS version on the Windows machine:

2. Quit the Xamarin.iOS Build Host app on the Mac.

3. Install the latest stable Xamarin.iOS, Mono, and Xamarin Studio versions on the Mac. You can do this either via Xamarin Studio under "Xamarin Studio -> Check for Updates", or using the individual installers:
Mono: http://download.xamarin.com/MonoFrameworkMDK/Macx86/MonoFramework-MDK-
Xamarin.iOS: http://download.xamarin.com/MonoTouch/Mac/monotouch-
Xamarin Studio: http://download.xamarin.com/studio/Mac/XamarinStudio-

4. Create a "new from template" Xamarin.iOS project in Xamarin Studio on the Mac, and make sure you can build, deploy, and debug that app on your iOS device.

5. Create a "new from template" Xamarin.iOS project in Visual Studio, pair to the build host as needed, etc.

6. Make sure the Configuration Manager has "iPhone" selected as the current deployment target, and that the project has "Build" checked ON.

7. Click the "Refresh build server info" button [1].
[1] http://www.screencast.com/t/J19PvNS4vI4x

If the iOS device still doesn't appear at this point, you can zip up and send back the following log directories:

## Xamarin for Visual Studio

## Xamarin.iOS Build Host (on the Mac)

(One way to access this folder is to select the "Go -> Go to Folder" menu item in Finder, and then copy and paste this path into the dialog.)

Thanks in advance for the additional information and tests! Hopefully we can get this sorted out quickly!


I have tried all the steps but no success.

Comment 1 Prashant manu 2014-09-29 02:51:36 UTC
Could you please add the logs from the following places?:
Xamarin for Visual Studio Log  
Location: %LOCALAPPDATA%\Xamarin\Log devenv file (with latest timestamp)
or Go to Help> and select option Zip Xamarin logs 
Xamarin.iOS Build Host (on the Mac) Location: ~/Library/Logs/Xamarin/MonoTouchVS
Comment 2 Firoz Khan 2014-09-29 03:16:46 UTC
Created attachment 8222 [details]

Log attached
Comment 3 Firoz Khan 2014-09-29 03:17:31 UTC
Created attachment 8223 [details]
Log Files

Log files attached.
Comment 4 Firoz Khan 2014-09-29 03:18:51 UTC
Added the Log files.

Please do needful.
Comment 5 Emanuel 2016-12-22 19:25:14 UTC
I'll mark this bug as resolved not reproducible, since I cannot reproduce it with latest stable bits.
Please feel free to reopen it if you can still reproduce the issue with current bits.