Bug 23336 - Different problems in iOS with orientation(-Change) on iPhone and iPad
Summary: Different problems in iOS with orientation(-Change) on iPhone and iPad
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-09-24 09:53 UTC by Fredy Wenger
Modified: 2014-12-12 11:30 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Screenshots and detail-descripton (see also "Description") (948.52 KB, application/pdf)
2014-09-24 09:53 UTC, Fredy Wenger

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Fredy Wenger 2014-09-24 09:53:38 UTC
Created attachment 8168 [details]
Screenshots and detail-descripton (see also "Description")

- The app has a Master-Detail-Navigation.
- First "short-data" are queried and shown on a page named "FreizeitGuide" (see screenshots to iPad in .pdf).
- If an entry in the Listview is selected, the detail-data are queried from webservices and shown on a page named "Details zu Freizeitanbveter"(see screenshots to iPhone in .pdf).

On iPhone only "the half" screen is used, if started in landscape-orientation.
On iPad, only one of two Icons is showed, if started in landscape-orientation.
=> Details see .pdf in the attachment.
Comment 1 Parmendra Kumar 2014-09-29 11:19:01 UTC
I have checked this issue and I am not able to reproduce it. Please check the Screencast and let me know if I missed anything. 
Could you please provide us some steps or sample project to reproduce it.

Screencast: http://www.screencast.com/t/L2DAT4sVth

Environment Info:
Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641

Xamarin (d5d1e8ffa3e94204a5f1c498938b2c71c73cf50e)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android (2a7b68212b17c903160fbd8e0106babb299d1be3)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS (8bd8158ae8c65c4fb50665dee520aa4ed86867ba)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 2 Fredy Wenger 2014-10-15 03:59:26 UTC
The problem with the iPhone seems to be fixed in the meantime.
The problem with iPad (only one Icon is shown), still exits.
I have sent a link to download the app about two weeks ago to support (MatrixGuide).
Reproduce issue:
- Debug app with an iPad (real device)
- Change the orientation of the device to landscape.
- Start the app on device
- Chose FreizeitGuide from main-menu
-> There is only one icon shown
- Close app
- change the orientation of the device to portrait
- start app
- Chose FreizeitGuide from main-menu
-> There are two icons showed
Comment 3 Parmendra Kumar 2014-10-20 10:11:22 UTC
Hello Fredy,
            I have checked this issue but unable to reproduce it, I have followed steps given in Comment 2, And I have getting same behavior as comment 1. Could you Please provide us sample project so that we can reproduce at my end.
Comment 4 Fredy Wenger 2014-10-20 12:35:27 UTC
As I wrote, the remainig Problem is the problem with the icon on a REAL IPAD.
In your example it seems, that the orientation of your app IS NOT CHANGED if you change the orientation of the EMULATOR
Please test on a real IPAD and enable orientation-change IN THE PROJECT-SETTINGS.
Comment 5 Parmendra Kumar 2014-11-05 12:33:52 UTC
I have tried to reproduce this issue on latest stable Xamarin builds with iOS device iPad 4(iOS 7.1) but I am still not able to reproduce this issue.

If you are still able to reproduce this issue with latest stable Xamarin builds then please include following piece of info.

1. Mtb server log - via Mac-Xamarin.iOS Build Host->View Build Host Log
2. iOS device log - from Xcode(Symbolicated Logs) 
3. Zip Xamarin logs - VS-Help-Zip Xamarin Log

We may have to see if a developer can figure out what's going on from the above piece of info.

Environment Info:
Windows 8.1
VS 2013, XVS

Mac Build host:
XiOS- (Business Edition)
Comment 6 Fredy Wenger 2014-11-17 06:23:46 UTC
The bug exists...
See: http://forums.xamarin.com/discussion/22910/masterdetailpage-right-aligned-toolbarbutton-hidden-in-ipad-landscape-mode#latest
As is wrote in the thread, I will do a re-test with the latest XF-Version (Pre-1) and - if the bug still exists - will send you my project (download-link)
Comment 7 Parmendra Kumar 2014-11-17 09:38:37 UTC
Yes Please, If you send me a sample download link it will be helpful to reproduce this issue at my end
Comment 8 Fredy Wenger 2014-11-17 10:13:15 UTC
Hi Parmendra
I was forced (unintentionally -> don't want) to update:
- XF to the latest Pre-1-Version
- IPad to iOS 8.1
In this combination (don't know if the Pre-1 or iOS8.1 is the reason), this bug (Icon not showed) seems to be fixed.
Unfortunatelly, therfore I have found various new bugs in this combination:
- Frame (showed as line) in an ListView is drawed over other Content
- Detail-page is not scrollable in landscape-orientation

And.. Slider don't work correct anymore (iPad AND iPhone)
Comment 9 Rui Marinho 2014-12-12 11:30:28 UTC
Hi Fredy i m closing this bug, because  like you said was fixed after pre1, if you have other bugs related to other issues, please open a new bugzilla issue for that particular issue.