Bug 2322 - Unable to install addin
Summary: Unable to install addin
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: 2.6
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
Depends on:
Reported: 2011-12-02 16:43 UTC by Aleck Agakhan
Modified: 2011-12-05 16:07 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

testcase (5.82 KB, application/octet-stream)
2011-12-02 16:44 UTC, Aleck Agakhan

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Aleck Agakhan 2011-12-02 16:43:14 UTC
MonoDevelop is unable to install addin due to the error "The following dependencies couldn't be resolved Ide v2.6.0" after I removed the addin and tried to install it again.
I tried to change the string "<Addin id="Ide" version="2.6.0"/>" to
"<Addin id="Ide" version="2.6"/>"
"<Addin id="Ide" version=""/>" but none of them works.
Comment 1 Aleck Agakhan 2011-12-02 16:44:57 UTC
Created attachment 989 [details]
Comment 2 Aleck Agakhan 2011-12-05 15:48:15 UTC
Ok. It seems I've got it. The problem is in namespace conflict.
When I specify the namespace "MonoDevelop.Samples.Addins" for my addin and set dependency like this

<Addin namespace = "MonoDevelop.Samples.Addins"...
    <Addin id="Ide"...

the system searches "MonoDevelop.Samples.Addins.Ide" instead of "MonoDevelop.Ide" and of course fails. So even if I specify somthing like <Addin id="MonoDevelop.Ide"... it fails anyway because it tries to find "MonoDevelop.Samples.Addins.MonoDevelop.Ide". The only way to make it work is to specify the namespace "MonoDevelop" for all addins. Is this a bug or made by design?
Comment 3 Mikayla Hutchinson [MSFT] 2011-12-05 16:07:36 UTC
By design, if the addin has a namespace then addin dependencies are resolved relative to that. You must do one of the following:
a) use absolute ids for the addin and its dependencies
b) ensure the namespace only has the part of the id that's common to the addin and its dependencies
c) globally qualify the dependency (using "::")

See http://monoaddins.codeplex.com/wikipage?title=Dependencies%20of%20an%20add-in&referringTitle=Reference%20Manual