Bug 23035 - No "Text Visualizers" when debugging Android and watching a string variable
Summary: No "Text Visualizers" when debugging Android and watching a string variable
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: Normal normal
Target Milestone: 4.0.0 (C6)
Assignee: Bugzilla
Depends on:
Reported: 2014-09-16 03:23 UTC by Arthur
Modified: 2016-05-10 16:57 UTC (History)
14 users (show)

Is this bug a regression?: ---
Last known good build:

difference between debugging a windows and Android application (110.50 KB, image/jpeg)
2014-09-16 03:23 UTC, Arthur

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Arthur 2014-09-16 03:23:05 UTC
Created attachment 8072 [details]
difference between debugging a windows and Android application

While debugging and watching a string variable, VS normally would offer several Text Visualizers to display larger or formatted strings. This is not the case when debugging an Android application.
See attached picture.
Comment 1 Sadik Ali 2014-09-16 06:13:43 UTC
I have checked this issue and able to reoroduce it.

I have tried following steps to reproduce it.
1.Create a Console  application.
2.Did some code in Program.cs and add breakpoint to hit string variable.
3.Create xamarin form applicaion.
4.Did some code in App.cs and add breakpoint to hit string variable .
5.Run the application

I observed that VS console application offer text Visualizer but xamarin application doesn't.

Screencast regarding same:

Environment Info:
 VS 2013 Professional Update 3
Comment 2 Arthur 2014-11-09 23:25:09 UTC
Any idea when this bug will be solved?

I really prefer using VS over Xamarin Studio as I use a QHD+ screen and Xamarin Studio does not work well with high DPI screens (or my eyes are getting to old).
Comment 4 Arthur 2015-02-22 11:47:35 UTC
Over five months have passed since I submitted this bug and so far no response!!!
Very disappointing!
Comment 5 Arthur 2015-02-24 06:00:07 UTC
I’m getting a bit disappointed in Xamarin.
Five and a half months have passed since I reported a bug (bug 23035). So far, nothing has been done to resolve it!
Debugging without text visualizers is an absolute pain when working with large strings such as json content.

Yes, I could use Xamarin Studio, which doesn’t have the bug,  instead of using VS.
However, I use Visual Studio because of several reasons including the VS Add-Ons (CodeRush) I use, and the fact Xamarin Studio doesn’t scale well on high-DPI displays (VS scales very well on high DPI displays).
Comment 6 Kent 2015-02-25 01:05:20 UTC
Same is true in iOS - no debugger visualizers in VS. This is making my current debugging effort very difficult indeed. I can't spit out my log entries to Debug.WriteLine because it's unbearably slow and is therefore failing to trigger the race condition I'm debugging, and I can't read my log messages in the debugger because I have no visualizers! All I can do is look at a massively long concatenated string with "\r\n" for every new line.

Very frustrating, and even more so when these issues get ignored.
Comment 9 Brendan Zagaeski (Xamarin Team, assistant) 2015-03-12 17:11:09 UTC
For any users seeing this issue, note that the importance has been adjusted to "Low" for precise bookkeeping. We still hope to have an assessment of this issue from the engineering team within the next few weeks.
Comment 10 brandon 2015-03-23 16:00:51 UTC
Please fix this. The current visualizer is useless. I have to copy the results in to a text editor, and do search and replace to make it use able. Here is an example of how terrible this is:

<GenericNameValueReport>\r\n  <FormItem Name=\"ApplicableAssets\" Value=\"\" />\r\n  <FormItem Name=\"Farm\" Value=\"\" />\r\n  <FormItem Name=\"Field(s)\" Value=\"\" />\r\n  <FormItem Name=\"Acreage\" Value=\"10.5120402433\" />\r\n  <FormItem Name=\"Date Stamp\" Value=\"2015-02-04T00:00:00\" />\r\n  <FormItem Name=\"Start Time\" Value=\"7:30 AM\" />\r\n  <FormItem Name=\"End Time\" Value=\"3:30 PM\" />\r\n  <FormItem Name=\"Crop\" Value=\"Tobacco\" />\r\n  <FormItem Name=\"Float Pool\" Value=\"3\" />\r\n  <FormItem Name=\"Seed Brand\" Value=\"Golden Leaf\" />\r\n  <FormItem Name=\"Crop Variety\" Value=\"GL NC196 Tobacco Seed\" />\r\n  <FormItem Name=\"Lot #\" Value=\"1536\" />\r\n  <FormItem Name=\"Tray\" Value=\"528\" />\r\n  <FormItem Name=\"Crop\" Value=\"Tobacco\" />\r\n  <FormItem Name=\"Float Pool\" Value=\"1\" />\r\n  <FormItem Name=\"Seed Brand\" Value=\"Golden Leaf\" />\r\n  <FormItem Name=\"Crop Variety\" Value=\"GL NC196 Tobacco Seed\" />\r\n  <FormItem Name=\"Lot #\" Value=\"1536\" />\r\n  <FormItem Name=\"Tray\" Value=\"528\" />\r\n  <FormItem Name=\"Crop\" Value=\"\" />\r\n  <FormItem Name=\"Float Pool\" Value=\"\" />\r\n  <FormItem Name=\"Seed Brand\" Value=\"\" />\r\n  <FormItem Name=\"Crop Variety\" Value=\"\" />\r\n  <FormItem Name=\"Lot #\" Value=\"\" />\r\n  <FormItem Name=\"Tray\" Value=\"\" />\r\n</GenericNameValueReport>"
Comment 11 PJ 2015-03-23 18:09:46 UTC
Agreed that priority seems incongruent with the issue at hand, back to 'normal' at least.

Aspirationally adding to the 3.11 milestone, but note that there's no guarantee this can make 3.11, it will depend on a development estimate.
Comment 13 brandon 2015-03-26 13:17:51 UTC
By the way - I am seeing this in iOS, I have not tried Android. I assume it's the same.
Comment 14 Christian Schmitt 2015-08-15 02:41:25 UTC
Its not fixed yet in iOS and VS2015 CE
Comment 15 Arthur 2015-08-28 23:47:08 UTC
Seriously guys, how long do we have to wait for this bug to be fixed?

This bug is now open for nearly a year, and so far NOTHING has been done to resolve it.