Bug 22998 - Can't enable gref logging
Summary: Can't enable gref logging
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 4.18.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2014-09-15 09:49 UTC by Holger Benl
Modified: 2014-09-15 14:16 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Holger Benl 2014-09-15 09:49:48 UTC
While trying to track down the issue described in Report #22991
I noticed that I couldn't enable gref logging using

adb shell setprop debug.mono.log gref

anymore. I tried this with Xamarin where gref logging
worked and with Xamarin 3.5.58 where gref logging didn't work.
Comment 1 Jonathan Pryor 2014-09-15 14:16:02 UTC
This is a regression in 4.16 which will be fixed in 4.18; see the Known Issues section in the release notes:


> This release unfortunately broke debug.mono.log handling;
> the debug.mono.log system property is ignored. Within Xamarin.Android 4.16,
> set the debug.mono.debug system property instead. The debug.mono.log
> system property will be fixed in Xamarin.Android 4.18.

Meaning, within 4.16 you should do:

    adb shell setprop debug.mono.debug gref