Bug 22973 - NSOutlineView.RemoveRows not decrementing row count
Summary: NSOutlineView.RemoveRows not decrementing row count
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) ()
Version: 1.10.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Chris Hamons
Depends on:
Reported: 2014-09-14 02:33 UTC by Cody Beyer (MSFT)
Modified: 2014-09-18 14:33 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Cody Beyer (MSFT) 2014-09-14 02:33:04 UTC
RowCount should decrement by the number of rows removed from the NSOutLineView using RemoveRows, however this behavior does not occur, and RowCount maintains the value it had prior to row removal.

Comment 1 Ram Chandra 2014-09-16 06:28:21 UTC
I have tried this issue but I am unable to reproduce this issue. 

Could you please provide test sample or test steps ? So that we can reproduce this issue at our end.
Comment 2 Timothy Risi 2014-09-18 14:33:07 UTC
According to Apple's documentation (in the NSOutlineView header), you aren't supposed to use RemoveRows with NSOutlineView, you should use RemoveItems instead.  I replied to the desk case to let him know and he said RemoveItems worked correctly for him.

Added the unavailable attribute to RemoveRows (and InsertRows) in a0f9e50d931a80b630078a9916dcc959fc1a25b7