Bug 22914 - App crashes on device, if breakpoint is set in an async-function
Summary: App crashes on device, if breakpoint is set in an async-function
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 3.6
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
: 22913 ()
Depends on:
Reported: 2014-09-12 06:24 UTC by Fredy Wenger
Modified: 2016-05-10 17:02 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

See comment (448.33 KB, application/pdf)
2014-11-04 11:20 UTC, Fredy Wenger

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Fredy Wenger 2014-09-12 06:24:02 UTC
If a breakpoint is set in a async-function the app on the device crashes if the breakpoint is reached.
The same is true for Android.
While it works with WP-Emulator.
Comment 1 narayanp 2014-09-12 11:02:48 UTC
*** Bug 22913 has been marked as a duplicate of this bug. ***
Comment 2 Parmendra Kumar 2014-11-04 09:24:53 UTC
I have checked this issue but I am not able to reproduce this issue. Please refer the Screencast : http://www.screencast.com/t/kqIxy1de

Please let me know if I missed anything.

Could you please provide Environment info and Ide log. 
You can get environment info via 'Help->About Microsoft Visual Studio->Copy Info and paste'.
For Ide log go to 'Help -> Zip Xamarin Log'

Environment Info:
Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641

Comment 3 Fredy Wenger 2014-11-04 11:20:33 UTC
Created attachment 8617 [details]
See comment

I have re-tested the bug.
It seems, as the bug is NOT directly related to set a breakpoint in an async-event.
See attachment (.pdf)
Comment 4 Parmendra Kumar 2014-11-07 12:29:16 UTC
I have tried to reproduce this issue on latest stable Xamarin builds but I am still not able to reproduce this issue.

If you are still able to reproduce this issue with latest stable Xamarin builds
then please include following piece of info.

1. Mtb server log - via Mac-Xamarin.iOS Build Host->View Build Host Log
2. iOS device log - from Xcode(Symbolicated Logs) 
3. Zip Xamarin logs - VS-Help-Zip Xamarin Log

We may have to see if a developer can figure out what's going on from the above
piece of info.

Environment Info:
Windows 8.1
VS 2013, XVS

Mac Build host:
XiOS- (Business Edition)
Comment 5 Fredy Wenger 2014-11-10 04:47:21 UTC
Hi Parmendra.
Yes I am able to reproduce this issue.

I am not able to set a breakpoint in a modal search-page.
iOS and also Android crashes hard before the breakpoint is reached.
Only WP works.
I think, it will be the best, if I submit you a download-link for the whole app, so you also can reproduce it easily.
=> Is this O.K. for you?
Comment 6 Parmendra Kumar 2014-11-10 05:18:53 UTC

Yes, if you provide us a repro sample it will be easy to reproduce at our end.

Comment 7 Fredy Wenger 2014-11-21 12:50:14 UTC
I have sent a link to my app and various bug-descriptions related to pre-3.
But.. as the behavior of the debugger changes by ever update (XF-Integration to VS), I'm not able to give you any advise to comprehend yet...
This for your information...
Comment 8 Fredy Wenger 2015-05-28 07:42:00 UTC
As I don't have received feedback from Xamarin to this issue and not other user has posted to this bug, I set this bug to resolved myself to help Xamarin by the clean-out of Bugzilla.
Maybe I later will post an new bug (then based on the newest versions).