Bug 22898 - "Symbol not found" when loading libobjc on 7.1 simulator
Summary: "Symbol not found" when loading libobjc on 7.1 simulator
Status: RESOLVED DUPLICATE of bug 22750
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: XI 8.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2014-09-11 21:23 UTC by Kevin Chen
Modified: 2014-09-11 22:01 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Kevin Chen 2014-09-11 21:23:16 UTC
I am building with Xamarin.iOS 8 from the beta channel. When I try to run my app in Debug/Simulator 7.1, it crashes immediately with exit code 5. When I run with Release/Sim 7.1, it prints this error: 

dyld: Symbol not found: __dealloc
  Referenced from: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
  Expected in: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.1.sdk/usr/lib/libobjc.A.dylib
 in /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

I found a similar problem here:


The solution, which was to set iOS Build > Linker behavior to "Link SDK Assemblies Only" worked.
Comment 1 Sebastien Pouliot 2014-09-11 22:01:37 UTC
Some new frameworks in iOS8 are causing side effects with OSX. Enabling the linker allows XI to remove the reference to (unused) frameworks so it can work around the issue (as long as there's no reference to the new frameworks).

*** This bug has been marked as a duplicate of bug 22750 ***