Bug 22879 - Go To Decleration" on types defined in Packages does not always work
Summary: Go To Decleration" on types defined in Packages does not always work
Status: RESOLVED DUPLICATE of bug 22697
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Assembly browser ()
Version: 5.2
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2014-09-11 13:23 UTC by Bernie Habermeier
Modified: 2014-09-12 01:16 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 22697

Description Bernie Habermeier 2014-09-11 13:23:12 UTC
See: http://forums.xamarin.com/discussion/comment/75719/#Comment_75719

This is still a problem in Xamarin Studio Version 5.3 Build 441.

make a new Xamarin Project -- say a PCL
add mvvmcross to it
go to the viewmodel template file it generates -- say ViewModels/FirsViewModel.cs and right-click on MvxViewModel and select "Go to Declaration" and you get the error.

Note: I just tried this like 7 times in a row, and always got the error. Then I just now tried it again, and didn't see the error. So the bug still exists, it just doesn't always reproduce.
Comment 1 Rajneesh Kumar 2014-09-12 01:16:03 UTC

*** This bug has been marked as a duplicate of bug 22697 ***