Bug 22619 - Image view added in storyboard doesn't appear in Today extension
Summary: Image view added in storyboard doesn't appear in Today extension
Alias: None
Product: iOS
Classification: Xamarin
Component: Pre-release ()
Version: 7.9.2.x
Hardware: Macintosh Mac OS
: High major
Target Milestone: 8.0.0 (iOS 8)
Assignee: Bugzilla
Depends on:
Reported: 2014-09-03 16:51 UTC by Mike Bluestein
Modified: 2014-09-03 20:57 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

test case (6.76 MB, application/zip)
2014-09-03 16:51 UTC, Mike Bluestein
Xcode test case (62.32 KB, application/zip)
2014-09-03 17:56 UTC, Mike Bluestein
another test case - this one works from Xamarin Studio (37.01 KB, application/zip)
2014-09-03 20:24 UTC, Mike Bluestein

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Mike Bluestein 2014-09-03 16:51:32 UTC
Created attachment 7907 [details]
test case

I added an image view in a storyboard and assigned it an image. When deployed to an iPhone 5, the image does not appear in the widget. See the included test case.

This is using XS from master.
Comment 1 Sebastien Pouliot 2014-09-03 16:55:44 UTC
Just to be clear it's not a blocker, i.e. we won't block the 8.0 same-day release for this (even if unsolved).
Comment 2 Sebastien Pouliot 2014-09-03 16:58:11 UTC
Is this a port of an existing Apple sample ? if so do you have a link to it ?

I do not think it's complete, i.e. it's not enough to put the .storyboard in the Info.plist
Comment 3 Mike Bluestein 2014-09-03 17:56:06 UTC
It''s created from our project template. I updated the architecture and app ids in the container project and the extension. The project template shipped with a UILabel in the storyboard. That worked. Then I deleted the UILabel and added the image view and the image. (I was suspecting something could be incorrect with the auto layout constraints)

I included a similar Xcode project for comparison.
Comment 4 Mike Bluestein 2014-09-03 17:56:32 UTC
Created attachment 7909 [details]
Xcode test case
Comment 5 Mike Bluestein 2014-09-03 20:24:17 UTC
Created attachment 7914 [details]
another test case - this one works from Xamarin Studio

Here's another test case, where I added the image view just like in the version that doesn't work. In this case however, I left the original label that is included in the extension's storyboard via the XS project template. This case works as expected.

Still not certain if it's a mistake I'm making or a bug.
Comment 6 Sebastien Pouliot 2014-09-03 20:57:31 UTC
I'm leaning toward mistake. 

- I can't see anything wrong with the code;

- If I copy the storyboard from the 2nd to 1st project then it works as expected

I'm a bit constraints-limited ;-) but I think the content of the original simply has no height (and maybe no width) and that's why nothing gets shown.

If you find anything, beside the storyboard, that could explain this (or is unexplained) then please re-open the bug and I'll have a 2nd look.