Bug 22409 - Xamarin Studio Locks up on Canceling an Open File Dialog
Summary: Xamarin Studio Locks up on Canceling an Open File Dialog
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 5.4
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2014-08-27 12:06 UTC by Kevin Mullins
Modified: 2016-09-16 05:49 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Image Cassettes (343.08 KB, image/png)
2014-08-27 12:07 UTC, Kevin Mullins
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Kevin Mullins 2014-08-27 12:06:31 UTC
On Mac OS X Yosemite Xamarin Studio locks up after canceling any open file dialog box.

Steps to reproduce:

1) Start Xamarin Studio
2) Open a project that is using image assets
3) Open Resources > Images.xcassets > AppIcons.appiconset
4) Double-click the Contents.json file to edit it.
5) Click on any image in the set.
6) Click the Cancel button.

The dialog box closes, but XS is still acting like the dialog box is open and has locked out all functionality. It beeps when you try to click inside of XS.

If it doesn't happen the first time you try it, keep opening and closing the Open File Dialog box... it usually starts this behavior after 3 or 4 tries.

This is happening everywhere there is an Open File Dialog Box.
Comment 1 Kevin Mullins 2014-08-27 12:07:52 UTC
Created attachment 7824 [details]
Image Cassettes

Clicking on any of the squares to select a new image locks up XS if canceled
Comment 2 Tajinder Singh 2014-08-28 04:26:22 UTC
I am unable to reproduce this Issue. This is the screencast for the same: http://www.screencast.com/t/Stnz0UEP7r

=== Xamarin Studio ===

Version 5.3 (build 435)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 3.8.0 ((no/62a857e)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000007

=== Xamarin.Android ===

Version: 4.16.0 (Indie Edition)
Android SDK: /Users/Admin_Mac/Desktop/Anddk/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Apple Developer Tools ===

Xcode 6.0 (6256.16)
Build 6A280e

=== Xamarin.iOS ===

Version: 7.4.0.107 (Indie Edition)
Hash: 326547f
Branch: 
Build date: 2014-08-25 14:54:57-0400

=== Xamarin.Mac ===

Version: 1.10.0.10 (Indie Edition)

=== Build Information ===

Release ID: 503000435
Git revision: 1e0c5fa7482a0356a71dfa469a3f71f5478a4660
Build date: 2014-08-25 12:17:42-04
Xamarin addins: 69708b283b171ea053d0edfbf09d98457d21fbee

=== Operating System ===

Mac OS X 10.10.0
Darwin Admin-Macs-Mac-mini.local 14.0.0 Darwin Kernel Version 14.0.0
    Sat Aug  9 00:14:02 PDT 2014
    root:xnu-2782.1.80~2/RELEASE_X86_64 x86_64

Even I have tried it with X.S 5.4 (Build 59) on this build as well I am unable to reproduce.

Could you please provide me build details on which you are getting this Issue?
Comment 3 Marius Ungureanu 2016-04-08 13:24:23 UTC
I've tried this locally and it works for me. If you see it again, please reopen the bug with more info (XS logs and version info).