Bug 22394 - Automatically generated outlets and actions file has double entries
Summary: Automatically generated outlets and actions file has double entries
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-08-27 06:50 UTC by Joe Cooper
Modified: 2014-08-28 16:31 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Joe Cooper 2014-08-27 06:50:28 UTC
Like so:


[Register ("SurveySelectionViewController")]
partial class SurveySelectionViewController
{
	[Outlet]
	MonoTouch.UIKit.UIView BodyContainer { get; set; }

	[Outlet]
	MonoTouch.UIKit.UIView BodyContainer { get; set; }

	[Outlet]
	MonoTouch.UIKit.NSLayoutConstraint BodyContainerHorizontalPositionConstraint { get; set; }

	[Outlet]
	MonoTouch.UIKit.NSLayoutConstraint BodyContainerHorizontalPositionConstraint { get; set; }

	...

And so on.

I was not modifying the file in question or its associated xib file when the error appear. I was editing other code and suddenly, it was like this. I suppose it must have synced. The Xib file opens correctly and I can't find anything amiss in it.
Comment 1 Jeffrey Stedfast 2014-08-28 16:31:49 UTC
The outlets aren't synced from the xib, they are synced from the .h and the .m files (just an FYI).

Fixed in 5.4