Bug 22245 - Breakpoints not hit for referenced assembly from solution's projects
Summary: Breakpoints not hit for referenced assembly from solution's projects
Status: RESOLVED FEATURE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 5.2
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-08-21 03:13 UTC by Emmanuel Mathot
Modified: 2014-08-26 03:06 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FEATURE

Description Emmanuel Mathot 2014-08-21 03:13:39 UTC
My solution has a simple web application that runs as default.
This application enables Mono.Addins to discover plugins through external dlls. Those dlls are produced by other projects inside the same solution. The main project references them as .Net assembly.

Before version 5.2.1, the breakpoints I set inside the "plugins" projects were hit during execution. Since 5.2.1, it is not the case anymore.
I cannot reference the "plugins" projects as project since the main project is already a dependency of the "plugins" projects and thus creating a cyclic dependency.

## Version information
Xamarin Studio 5.2.1
Mono 3.4.0
Mono.Addins 1.1
Comment 1 Jeffrey Stedfast 2014-08-25 15:18:54 UTC
You probably have "Debug project code only" enabled in your debugger preferences.