Bug 22152 - Autocomplete error with DataTemplate
Summary: Autocomplete error with DataTemplate
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2014-08-17 19:43 UTC by Paul Johnson
Modified: 2017-01-10 12:31 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Paul Johnson 2014-08-17 19:43:18 UTC
If I have

var foo = new DataTemplate

the autocomplete gives 3 options, the first with no parameter. If this is selected, the text editor complains saying that there is not a version of DataTemplate that takes no options

=== Xamarin Studio ===

Version 5.3 (build 423)
Installation UUID: f3d1a29c-1ba2-4a83-a193-1087efe91a85
Runtime:
	Mono 3.8.0 ((no/62a857e)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000007

=== Apple Developer Tools ===

Xcode 6.0 (6256.8)
Build 6A279r

=== Xamarin.Mac ===

Version:

=== Xamarin.iOS ===

Version: 7.9.3.52 (Business Edition)
Hash: 1686c40
Branch: 
Build date: 2014-08-11 15:30:23-0400

=== Xamarin.Android ===

Version: 4.17.0 (Business Edition)
Android SDK: /Users/PFJ/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.0    (API level 11)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

=== Build Information ===

Release ID: 503000423
Git revision: f4bb573b38a18c9f5400d8734eada2d5610deae4
Build date: 2014-08-12 17:26:33-04
Xamarin addins: 0961e1860cd1dcb4e47062f25c40d224979a02fb

=== Operating System ===

Mac OS X 10.10.0
Darwin Pauls-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Tue Jul 29 16:22:25 PDT 2014
    root:xnu-2782.1.62~4/RELEASE_X86_64 x86_64
Comment 1 Ram Chandra 2014-08-18 14:35:18 UTC
I have checked this issue and I am getting the same behavior.

Steps I followed:

1. Create Blank App (Xamarin.Forms Portable) on XS.
2. Create a new content page on XS.
3. Write the following line. 
    
  var test = new DataTemplate();

When I write the following statement on XS.
      var test = new DataTemplate();

I observed that when we type DataTemplate(), it shows three overload. First overload doesn't contain any argument and when we complete the DataTemplate() it shows two overloads. I observed that when use the default  constructor of "DataTemplate" class. It shows an error message i.e "The type DataTemplate doesn't contain a constructor that take '0' arguments.

I have also checked the definition of "DataTemplate" class and observed the "DataTemplate" class has three constructor and the default constructor is internal constructor. 
 
Screencast: http://www.screencast.com/t/AH7RsV31tC

Environment Info:

=== Xamarin Studio ===

Version 5.3 (build 427)
Installation UUID: 6ea47b0d-1852-4aaf-808d-373ff0a5002b
Runtime:
	Mono 3.8.0 ((no/62a857e)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000007

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.iOS ===

Version: 7.4.0.102 (Business Edition)
Hash: 141adb9
Branch: 
Build date: 2014-08-15 12:54:28-0400

=== Xamarin.Android ===

Version: 4.16.0 (Business Edition)
Android SDK: /Users/jatin66/Desktop/Backup/android-sdk-macosx
	Supported Android versions:
		1.6   (API level 4)
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.0   (API level 11)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Xamarin.Mac ===

Version: 1.10.0.9 (Business Edition)

=== Build Information ===

Release ID: 503000427
Git revision: b731d769195292820b25b6f9621a7a9decb3fff6
Build date: 2014-08-14 03:26:41-04
Xamarin addins: aaf33dfafebf0d688f6e1a1eb58bced21de89a1d

=== Operating System ===

Mac OS X 10.9.3
Darwin Jatin66s-iMac.local 13.2.0 Darwin Kernel Version 13.2.0
    Thu Apr 17 23:03:13 PDT 2014
    root:xnu-2422.100.13~1/RELEASE_X86_64 x86_64
Comment 2 David Karlaš 2015-09-09 10:32:01 UTC
This is not XF AddIn bug but C# Binding bug, it shouldn't display internal constructor as option.
Comment 3 Mike Krüger 2017-01-10 12:31:59 UTC
Shouldn't happen in the 6.x line anymore. closing