Bug 21841 - Reason. Argument is out of Range. Tried with 2 Sample Project
Summary: Reason. Argument is out of Range. Tried with 2 Sample Project
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.16.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2014-08-05 14:35 UTC by Nishith Rastogi
Modified: 2017-06-27 18:27 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Build Log (233.20 KB, text/plain)
2014-08-05 14:35 UTC, Nishith Rastogi

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Nishith Rastogi 2014-08-05 14:35:39 UTC
Created attachment 7593 [details]
Build Log


I am on Windows 7, Xamarin Studio 5.2 (build 386).

I download the T-Shirt Store APP, as well as the Android API Demo app from your sample page. I open the apps in Xamarin Studio, right  click and mark them as 'Set As Startup Project'. Then on clicking the build button, upon the package creation step I end up with:

Line 1319, Unexpected Error - Please file a bug at http://bugzilla.zamarin.com. Reason: Argument is out of range. (XA0000)

This is happening consistently for both projects, I haven't changed any thing in code. Attaching the build log 

Comment 1 Rajneesh Kumar 2014-08-21 12:09:57 UTC
I have checked this issue and not able to reproduce. Here is the screencast for the same:

Screencast: http://www.screencast.com/t/yj9fvWlAD

Could you please provide us Build Information and IDE logs ? So that we can reproduce this issue at our end.

To get Ide Log: Help=>Open Log directory

To get Build Info for XS: Help=>About=>Show Details=>Copy Information

To get Build Info for XVS: Help=>About Microsoft Visual Studio=>Copy info

Environment Info:

=== Xamarin Studio ===

Version 5.2 (build 386)
Installation UUID: 3b924754-5196-440a-b42b-05ebb3a3082e
	Microsoft .NET 4.0.30319.18408
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 4.14.0 (Business Edition)
Android SDK: D:\Android\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: C:\Program Files\Java\jdk1.6.0_31
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 502000386
Git revision: e6a54dee5376e6e7a2d9982695b060fddc09e65d
Build date: 2014-08-04 14:07:09-04
Xamarin addins: 2b5a5c26ac2ee74c6e91a8d24ef44d0ca9cb74d0

=== Operating System ===

Windows 6.1.7601.65536
Comment 2 Chris Hardy [MSFT] 2017-06-27 18:27:00 UTC
Unfortunately, we’re unable to reproduce this report. If this issue is still occurring for you, please reopen this issue and attach a reproduction to the bug by starting with a clean Xamarin.Android project adding just the code necessary to demonstrate the issue.