Bug 21838 - / or \ characters added to the beginning of a filename in Xamarin Studio's solution pad moves file to the root folder and filename becomes locked
Summary: / or \ characters added to the beginning of a filename in Xamarin Studio's so...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Management ()
Version: 5.2
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-05 14:08 UTC by Kent Green [MSFT]
Modified: 2017-03-20 23:44 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Kent Green [MSFT] 2014-08-05 14:08:01 UTC
--Overview--
While attempting to track and reproduce a user's reported error that they were unable to edit filenames in Xamarin Studio; I found that placing the / OR \ characters in front of a filename moved that file to the root directory; and locked it so that the filename could no longer be changed in Xamarin Studio, though the displayed filename would appear changed in the solution bar.

--Demo of bug--
http://screencast.com/t/NY78O7St


--Build Information--
=== Xamarin Studio ===

Version 5.2 (build 386)
Installation UUID: 7d1f6346-03b4-4b5f-b01b-a16d3a1c25a0
Runtime:
	Microsoft .NET 4.0.30319.18444
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.25

=== Xamarin.Android ===

Version: 4.14.0 (Business Edition)
Android SDK: C:\Program Files (x86)\Android\android-sdk
	Supported Android versions:
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode)

=== Build Information ===

Release ID: 502000386
Git revision: e6a54dee5376e6e7a2d9982695b060fddc09e65d
Build date: 2014-08-04 14:07:09-04
Xamarin addins: 2b5a5c26ac2ee74c6e91a8d24ef44d0ca9cb74d0

=== Operating System ===

Windows 6.1.7601.65536 (64-bit)
Comment 2 Kent Green [MSFT] 2014-08-05 14:51:50 UTC
Possibly related bug:
https://bugzilla.xamarin.com/show_bug.cgi?id=21842
Comment 3 Rajneesh Kumar 2014-08-06 08:58:55 UTC
I have checked this issue and able to reproduce it.

Steps I followed:

1.Create Android application
2.Add Class File To the Properties folder
3.Rename Files With using '\FileName'
4.Files gets renamed

Screencast: http://www.screencast.com/t/GcYzwrdP

Environment info:

=== Xamarin Studio ===

Version 5.2 (build 386)
Installation UUID: 851620d2-e950-4682-b459-991ccec9d895
Runtime:
 Microsoft .NET 4.0.30319.18408
 GTK+ 2.24.22 (MS-Windows theme)
 GTK# 2.12.25

=== Xamarin.Android ===

Version: 4.14.0 (Enterprise Edition)
Android SDK: D:\SDK\AndroidSDK
 Supported Android versions:
  2.1   (API level 7)
  2.2   (API level 8)
  2.3   (API level 10)
  3.1   (API level 12)
  3.2   (API level 13)
  4.0   (API level 14)
  4.0.3 (API level 15)
  4.1   (API level 16)
  4.2   (API level 17)
  4.3   (API level 18)
  4.4   (API level 19)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_31
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 502000386
Git revision: e6a54dee5376e6e7a2d9982695b060fddc09e65d
Build date: 2014-08-04 14:07:09-04
Xamarin addins: 2b5a5c26ac2ee74c6e91a8d24ef44d0ca9cb74d0

=== Operating System ===

Windows 6.1.7601.65536 (64-bit)
Comment 4 Kent Green [MSFT] 2017-03-20 23:39:48 UTC
I can no longer reproduce this issue on Windows or on Mac, so I am marking this bug as RESOLVED NOT_REPRODUCIBLE.
Comment 5 Kent Green [MSFT] 2017-03-20 23:44:56 UTC
Sorry, I forgot the version info for where I no longer see the issue. This is from Windows since that was the basis in the description; however the same Xamarin Studio version in Mac does not encounter the issue either:

=== Xamarin Studio Community ===

Version 6.3 (build 835)
Installation UUID: 7d1f6346-03b4-4b5f-b01b-a16d3a1c25a0
Runtime:
	Microsoft .NET 4.0.30319.42000
	GTK+ 2.24.26 (Light theme)
	GTK# 2.12.38

=== NuGet ===

Version: 3.5.0.0

=== Xamarin.Profiler ===

'/Applications/Xamarin Profiler.app' not found

=== Xamarin.Android ===

Version: 7.2.0.1 (Xamarin Studio Community)
Android SDK: C:\Program Files (x86)\Android\android-sdk
	Supported Android versions:
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)

SDK Tools Version: 25.1.6
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.3

Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Build Information ===

Release ID: 603000835
Git revision: 85b3e62f47fa6b88ee9d988ec28697c255530116
Build date: 2017-03-14 17:51:37-04
Xamarin addins: 72659ab8135cd8896160ad264cf0c1b6615e9d77
Build lane: monodevelop-windows-d15-1

=== Operating System ===

Windows 10.0.14393.0 (64-bit)