Bug 21674 - Exception when Upload to device
Summary: Exception when Upload to device
Status: RESOLVED DUPLICATE of bug 21205
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: 5.1
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Greg Munn
URL:
Depends on:
Blocks:
 
Reported: 2014-07-29 17:07 UTC by Robert Fuszenecker
Modified: 2014-08-21 12:37 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Project (4.89 MB, application/zip)
2014-07-29 17:07 UTC, Robert Fuszenecker
Details
Project (6.57 MB, application/octet-stream)
2014-08-01 17:25 UTC, Robert Fuszenecker
Details
screenshot (161.62 KB, image/png)
2014-08-01 17:26 UTC, Robert Fuszenecker
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 21205

Description Robert Fuszenecker 2014-07-29 17:07:43 UTC
Created attachment 7525 [details]
Project

I received an exception when I tried to upload the code to the device.

System.NullReferenceException: Object reference not set to an instance of an object.
   at MonoDevelop.MonoDroid.MonoDroidProject.GetDeviceTarget(IProgressMonitor monitor, AndroidDevice& device)
   at MonoDevelop.MonoDroid.DefaultUploadToDeviceHandler.<>c__DisplayClass2.<Run>b__1()

Project attached.
Comment 1 Rajneesh Kumar 2014-07-30 03:09:28 UTC
Hi Robert,
          I tried to reproduce this issue on my machine but the sample project
given by you is not going to build and it has TWO build  error. These are mentioned in gist: https://gist.github.com/saurabh360/3f8f8b92c747918d351c

Could You please provide me the sample project again that has no build error? So that I can Reproduce this issue at my end.

Thanks

Screencast:- http://screencast.com/t/vL3g7ex8hXv


Environment Info:
=== Xamarin Studio ===

Version 5.1.4 (build 0)
Installation UUID: 474db917-e8f4-4d6a-a188-890200ead0e0
Runtime:
	Microsoft .NET 4.0.30319.18408
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.25

=== Xamarin.Android ===

Version: 4.12.6 (Trial Edition)
Android SDK: C:\Users\360 Logica\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: C:\Program Files\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode)

=== Build Information ===

Release ID: 501040000
Git revision: 7d45bbe2ee22625f125d0c52548524f02d005cca
Build date: 2014-07-14 13:38:46-04
Xamarin addins: c78f1d88e57baa928aeee1484d96e6f8edf8de33

=== Operating System ===

Windows 6.2.9200.0
Comment 2 Greg Munn 2014-07-30 11:25:57 UTC
This is the same issue as bug 21205

*** This bug has been marked as a duplicate of bug 21205 ***
Comment 3 Robert Fuszenecker 2014-08-01 17:25:25 UTC
Created attachment 7567 [details]
Project

Project
Comment 4 Robert Fuszenecker 2014-08-01 17:26:09 UTC
Created attachment 7568 [details]
screenshot
Comment 5 simone.busoli 2014-08-21 12:04:00 UTC
I'm having exactly the same same issue. Any idea how to fix that? (and BTW, the bug this is marked as duplicate of seems unrelated).
Comment 6 Greg Munn 2014-08-21 12:10:12 UTC
Simone, different symptoms, same bug. Try changing the start up project to be the android project. Also, this should be fixed in 5.3 - could you please try it with that version and let me know.
Comment 7 simone.busoli 2014-08-21 12:12:01 UTC
How do I get 5.3? I just installed it and it's this:

=== Xamarin Studio ===

Version 5.2.1 (build 1)
Installation UUID: cf10a683-11ec-4c1b-a2d1-287792229883
Runtime:
	Microsoft .NET 4.0.30319.18444
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.25

=== Xamarin.Android ===

Version: 4.14.0 (Trial Edition)
Android SDK: C:\Program Files (x86)\Android\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0.3 (API level 15)
		4.4   (API level 19)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 502010001
Git revision: d06832ce9807d6be24aca225457e8b37c7669f6f
Build date: 2014-08-07 14:35:09-04
Xamarin addins: 1de032531be4cecf2f39dbee3b87aac78204058c

=== Operating System ===

Windows 6.1.7601.65536 (64-bit)
Comment 8 Greg Munn 2014-08-21 12:22:50 UTC
It's in beta, you can switch to the beta channel when you check for updates. you can switch back afterwards if you want / need.
Comment 9 simone.busoli 2014-08-21 12:37:12 UTC
Ok, I confirm it's fixed in 5.3. It would be useful to track which version has the fix.