Bug 21672 - Exception when I tried to install
Summary: Exception when I tried to install
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Deployment ()
Version: 5.1
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-07-29 16:55 UTC by Robert Fuszenecker
Modified: 2014-10-31 06:35 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Project (4.89 MB, application/zip)
2014-07-29 17:02 UTC, Robert Fuszenecker
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 21672 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Robert Fuszenecker 2014-07-29 16:55:34 UTC
Right click on the Xamarin.Android project, Tools -> Install, Select Desktop:

System.UnauthorizedAccessException: Access to the path 'C:\Program Files (x86)\Xamo.Android' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj, Boolean checkHost)
   at System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
   at System.IO.Directory.CreateDirectory(String path)
   at MonoDevelop.Deployment.InstallResolver.CopyFile(IProgressMonitor monitor, String src, String dest, DeployFileAttributes atts)
   at MonoDevelop.Deployment.InstallResolver.InstallEntry(IProgressMonitor monitor, DeployContext ctx, SolutionItem entry, ConfigurationSelector configuration)
   at MonoDevelop.Deployment.InstallResolver.Install(IProgressMonitor monitor, SolutionItem entry, String appName, String prefix, ConfigurationSelector configuration)
   at MonoDevelop.Deployment.DeployService.Install(IProgressMonitor monitor, SolutionItem entry, String prefix, String appName, ConfigurationSelector configuration)
   at MonoDevelop.Deployment.Gui.DeployOperations.Install(SolutionItem entry, ConfigurationSelector configuration)
   at MonoDevelop.Deployment.InstallHandler.Run()
   at MonoDevelop.Components.Commands.CommandHandler.Run(Object dataItem)
   at MonoDevelop.Components.Commands.CommandHandler.InternalRun(Object dataItem)
   at MonoDevelop.Components.Commands.CommandManager.DefaultDispatchCommand(ActionCommand cmd, CommandInfo info, Object dataItem, Object target, CommandSource source)
   at MonoDevelop.Components.Commands.CommandManager.DispatchCommand(Object commandId, Object dataItem, Object initialTarget, CommandSource source)

Xamo is the name of the project.
Comment 1 Robert Fuszenecker 2014-07-29 17:02:25 UTC
Created attachment 7524 [details]
Project
Comment 2 Mikayla Hutchinson [MSFT] 2014-07-29 21:23:59 UTC
Yes, the desktop deployment addin doesn't support Android projects. its command shouldn't be showing up for project types it doesn't support.

TBH I would suggest we remove it entirely as I question the usefulness of something that "installs" desktop apps but doesn't actually create redistributable installers.
Comment 3 Danish Akhtar 2014-10-31 06:35:25 UTC
I have checked this issue with:
XS 5.5.3(build 6)
XVS 3.7.230

We are also getting this issue, getting error when we right click on the Xamarin.Android project, Tools -> Install.