Bug 21419 - Info.plist Main Interface dropdown empty, not searching for Storyboards (TRIAL)
Summary: Info.plist Main Interface dropdown empty, not searching for Storyboards (TRIAL)
Status: RESOLVED DUPLICATE of bug 20706
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.1
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-07-17 23:12 UTC by Ish Said
Modified: 2014-07-22 09:42 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

screenshot of empty dropdown (23.43 KB, image/png)
2014-07-17 23:12 UTC, Ish Said

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ish Said 2014-07-17 23:12:06 UTC
Created attachment 7415 [details]
screenshot of empty dropdown

This could be a regression of Bug 10748?  This issue only occurs with Visual Studio.  You can reproduce it with the Trial license with any of the default projects.  Single View will load, but the dropdown will be empty.  If you start with a blank project like I did, then you have to do the workaround I posted on the forums:


I have found a fix/workaround. But this seems like a big to me as they don't mention anything like this in any tutorials I've seen and the field still is blank, but as a workaround here is what I did.

I opened the Info.plist file generated by Visual Studio and compared it to the one generated by Xamarin Studio.
The tags were different. In Xamarin it asked for the UIMainStoryboardFile, where the Visual Studio asked for the NCMainNibFile

So I changed:



And then I was able to run the app from Visual Studio after that using this storyboard file. Again, note that when I go to the Info.plist proper interface the drop-down is still empty. Seems like the plugin isn't using this file correctly or scanning for storyboards? Maybe it's just my setup. I did some searches on some old bugs, and saw this in an earlier release I think, but I can't seem to find the post again at this moment.
Comment 1 Ish Said 2014-07-17 23:17:07 UTC
This is not an issue if you copy the files to the mac and build/run with Xamarin Studio.

Running Visual Studio 2013. I have tried this on a MacBook Pro running Mavericks and a VM of Windows 7 Pro.  I have also tried this under another account with a Mac Mini Mavericks and a PC running 8.1 Pro.
Comment 2 Ish Said 2014-07-17 23:19:34 UTC
Corrected version of Visual Studio Addin to 3.1.224
Xamarin Build Host
Xamarin Studio 5.1.4
Comment 3 Prashant manu 2014-07-22 09:42:56 UTC

*** This bug has been marked as a duplicate of bug 20706 ***