Bug 21262 - xamarin crashes when opening
Summary: xamarin crashes when opening
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 5.2
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2014-07-11 10:06 UTC by Jon Minton
Modified: 2014-07-15 12:10 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Log file from crash on startup (148.41 KB, application/octet-stream)
2014-07-11 19:15 UTC, Jon Minton
Details
My entire logs folder zipped up. (156.71 KB, application/octet-stream)
2014-07-15 10:18 UTC, Jon Minton
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jon Minton 2014-07-11 10:06:09 UTC
Xamarin Studio crashes when opening the program. Ide*.log shows the error

An unhandled exception has occured. Terminating MonoDevelop? True
System.ApplicationException: The type node builder MonoDevelop.PackageManagement.NodeBuilders.ProjectPackagesFolderNodeBuilder can't be used in this context because the type MonoDevelop.PackageManagement.NodeBuilders.ProjectPackagesFolderNode is already handled by MonoDevelop.PackageManagement.NodeBuilders.ProjectPackagesFolderNodeBuilder
   at MonoDevelop.Ide.Gui.Components.ExtensibleTreeView.SetBuilders(NodeBuilder[] buildersArray, TreePadOption[] options)
   at MonoDevelop.Ide.Gui.Components.ExtensibleTreeView.UpdateBuilders(NodeBuilder[] builders, TreePadOption[] options)
   at MonoDevelop.Ide.Codons.SolutionPadCodon.OnExtensionChanged(Object s, ExtensionEventArgs args)
   at Mono.Addins.ExtensionEventHandler.Invoke(Object sender, ExtensionEventArgs args)
   at Mono.Addins.ExtensionContext.NotifyExtensionsChanged(ExtensionEventArgs args)
   at Mono.Addins.ExtensionContext.ActivateAddinExtensions(String id)
   at Mono.Addins.Database.AddinDatabase.Update(IProgressStatus monitor, String domain)
   at Mono.Addins.Database.AddinDatabase.Repair(IProgressStatus monitor, String domain)
   at Mono.Addins.AddinRegistry.Rebuild(IProgressStatus monitor)
   at MonoDevelop.Ide.IdeStartup.Main(String[] args, IdeCustomizer customizer)
   at Xamarin.Startup.MainClass.Main(String[] args)

Additional Information:
I had Xamarin crashing on startup before with a different error right after an update. It would continually crash when opening and I had to launch it once using "Run as Admin" (UAC, I already have privileges), but this time I didn't get an update. For grins I went ahead and launched using run as admin, but to no avail. I can't open Xamarin in the interim.
Comment 1 Lluis Sanchez 2014-07-11 10:29:03 UTC
Could you please attach the whole log file?
Comment 2 Jon Minton 2014-07-11 19:15:19 UTC
Created attachment 7343 [details]
Log file from crash on startup
Comment 3 Jon Minton 2014-07-11 19:15:41 UTC
I've attached it. Thanks for the reply, let me know if you need anything else.
Comment 5 Lluis Sanchez 2014-07-15 06:11:31 UTC
Could you please try this?

1) Open a console
2) Cd to the Xamarin Studio location (for example, C:\Program Files\Xamarin Studio\bin)
3) Start Xamarin studio using this command: XamarinStudio.exe /no-splash

Xamarin Studio should start using this command, although you will probably get an error message. Can you attach the new Ide log file after doing the above?
Comment 6 Jon Minton 2014-07-15 10:16:21 UTC
When I ran it from the command line with the /no-splash argument it opened without error. The very first time I did this it seemed to do some initialization it wasn't able to do before because it took several minutes to open. After this I attempted to open it through the Start menu like normal. It appeared that this resolved the issue and I was able to open without error. I opened it several times without error, opened a project, compiled and all seemed well. 

Maybe 5 or 6 opens later I experienced the same crash on start up and the logs appeared to show the same error. So I ran with the command line given and it opened without error again. I attempted to run it using the command line without the /no-splash argument and it crashed again. My current state is I can open it with the argument every time, both from command line or from the task bar after changing my shortcut to include the argument. Without the argument it seems to be hit or miss now, but at least 1 of every 3 times it crashes. I'm attaching my log files, but I at least have a workaround for now.
Comment 7 Jon Minton 2014-07-15 10:18:20 UTC
Created attachment 7363 [details]
My entire logs folder zipped up.

This is after I started running with the /no-splash argument and includes several opens with and without the command. Opening with the argument never crashed, but opening without it crashed pretty regularly although there were time it did not.
Comment 8 Lluis Sanchez 2014-07-15 10:37:15 UTC
Are you seeing a dialog that asks you to validate an untrusted HTTP certificate when you start Xamarin Studio?
Comment 9 Jon Minton 2014-07-15 11:14:01 UTC
Yes I see that every time I open.
Comment 10 Lluis Sanchez 2014-07-15 12:10:04 UTC
Ok, the crash is caused by a bad interaction of that dialog with the splash window.  This should be fixed in 5.2 (currently in the beta channel).