Bug 2095 - Mono compilation halts during an mdoc type load exception
Summary: Mono compilation halts during an mdoc type load exception
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2011-11-20 06:07 UTC by Dylan Borg
Modified: 2012-01-14 03:22 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Dylan Borg 2011-11-20 06:07:29 UTC
The compilation of mono from GIT (retrieved Nov 20 2011) fails to finish because of a TypeLoadException during an mdoc pass on 4.5 profile libraries. Here is an excerpt from my terminal:

make[7]: Leaving directory `/home/dylan/Desktop/mono/mcs/errors'
make[6]: Leaving directory `/home/dylan/Desktop/mono/mcs/errors'
make[6]: Entering directory `/home/dylan/Desktop/mono/mcs/docs'
make all-local
make[7]: Entering directory `/home/dylan/Desktop/mono/mcs/docs'
MDOC    [net_4_5] cs-errors.tree
mdoc: A type load exception has occurred.
See `mdoc help' for more information.
make[7]: *** [cs-errors.tree] Error 1
make[7]: Leaving directory `/home/dylan/Desktop/mono/mcs/docs'
make[6]: *** [do-all] Error 2
make[6]: Leaving directory `/home/dylan/Desktop/mono/mcs/docs'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/dylan/Desktop/mono/mcs'
make[4]: *** [profile-do--net_4_5--all] Error 2
make[4]: Leaving directory `/home/dylan/Desktop/mono/mcs'
make[3]: *** [profiles-do--all] Error 2
make[3]: Leaving directory `/home/dylan/Desktop/mono/mcs'
make[2]: *** [all-local] Error 2
make[2]: Leaving directory `/home/dylan/Desktop/mono/runtime'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dylan/Desktop/mono'
make: *** [all] Error 2
Comment 1 Zoltan Varga 2011-11-20 09:09:20 UTC
Try a full rebuild, i.e. make distclean.
Comment 2 Dylan Borg 2011-11-20 10:09:54 UTC
ok i will try
Comment 3 Dylan Borg 2011-11-20 10:11:45 UTC
Was it bad that I used make -j8 to build?
Comment 4 Dylan Borg 2011-11-20 10:24:11 UTC
With a re-fetch of the code from GIT and remake of it still gets stuck at the same point. Note that I am using the master branch of the code.
Comment 5 Zoltan Varga 2011-11-20 14:06:28 UTC
Does it work if you do a full rebuild without -j8 ?
Comment 6 Dylan Borg 2011-11-20 14:22:10 UTC
no, it worked by commenting out part of some makefiles even on -j8 and without it. I had to disable installs and builds of all monodoc trees.
Comment 7 Zoltan Varga 2011-11-21 23:00:49 UTC
Should be fixed now.
Comment 8 Dylan Borg 2011-11-22 02:50:01 UTC
It now worked fin even with make -j*, Thanks. I can now make a preliminary ubuntu package for it.
Comment 9 Dylan Borg 2012-01-11 02:14:59 UTC
It is now failing again saying some files were not found:

Merging: mono-api-class.html
Merging: mono-api-metadata.html
Merging: mono-api-unsorted.html
Merging: mono-api-reflection.html
Merging: mono-api-profiler.html
Merging: mono-api-vm.html
Merging: mono-api-gchandle.html
Merging: mono-api-types.html
Merging: mono-api-codegen.html
Merging: mono-api-jitinternal.html
Merging: mono-api-embedding.html
Merging: mono-api-jit.html
Merging: mono-api-debug.html
touch deploy/.stamp
cd . && make -f docs.make topdir=../mcs mono-file-formats.tree
cd . && make -f docs.make topdir=../mcs mono-tools.tree
cd . && cp -f api-style.css deploy
cd . && make -f docs.make topdir=../mcs monoapi.tree
make[3]: Entering directory `/home/dylan/Desktop/mono/docs'
make[3]: Entering directory `/home/dylan/Desktop/mono/docs'
MDOC    [net_4_5] mono-file-formats.tree
MDOC    [net_4_5] mono-tools.tree
make[3]: Entering directory `/home/dylan/Desktop/mono/docs'
MDOC    [net_4_5] monoapi.tree
make[3]: Leaving directory `/home/dylan/Desktop/mono/docs'
Warning: file deploy/mono-api-assembly.html#cil_assembly_load not found
Warning: file deploy/mono-api-image.html#cil_image_open not found
make[3]: Leaving directory `/home/dylan/Desktop/mono/docs'
make[3]: Leaving directory `/home/dylan/Desktop/mono/docs'
make[2]: Leaving directory `/home/dylan/Desktop/mono/docs'
make[2]: Entering directory `/home/dylan/Desktop/mono'
make[2]: Leaving directory `/home/dylan/Desktop/mono'
make[1]: Leaving directory `/home/dylan/Desktop/mono'
Comment 10 Dylan Borg 2012-01-11 02:17:19 UTC
Might fix if make is called again after the first run.