Bug 20864 - Project doesn't build after adding a reference to Amazon.InAppPurchasing
Summary: Project doesn't build after adding a reference to Amazon.InAppPurchasing
Alias: None
Product: Android
Classification: Xamarin
Component: Bindings ()
Version: 4.14.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Atsushi Eno
Depends on:
Reported: 2014-06-24 23:43 UTC by Zhenya
Modified: 2016-08-08 07:55 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Sample project that doesn't build after adding the references. Not quite the same error though. (2.47 MB, application/zip)
2014-06-24 23:43 UTC, Zhenya

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Zhenya 2014-06-24 23:43:42 UTC
Created attachment 7173 [details]
Sample project that doesn't build after adding the references. Not quite the same error though.

Can not build my project anymore after adding the reference. The linker gives the following crypted error message: /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Exception while loading assemblies: System.InvalidOperationException: Failed to load assembly App.Android.UI.dll at Xamarin.Android.Tasks.ResolveAssemblies.Execute () [0x00000] in :0 (App.Android.UI)

It looks like it is a references problem because adding Amazon.InAppPurchasing works for an empty project.. Maybe a conflict with some of the following references I already have: DropboxSync.Android, GooglePlayServicesLib, Mono.Android.Support.v4.
Comment 1 Shruti 2014-06-26 06:10:09 UTC
I have checked this issue but not able to reproduce it. I did the followed steps to reproduce it.
1. I have created a new solution.
2. Added given project in the solution and build it.
3. Added 'Mono.Android.Support.v4' from reference of the project and build it.
4. Again, added GooglePlayServicesLib.dll and build it.

It build successfully every time.

Screencast : http://screencast.com/t/wfmb9uoJa

Environment Info :
=== Xamarin Studio ===

Version 5.1.1 (build 1)
Installation UUID: 1151d3d9-29c1-4339-b53c-a54856b47901
	Mono 3.6.0 ((no/f6ef3e7)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 306000000

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.Android ===

Version: 4.14.0 (Enterprise Edition)
Android SDK: /Users/shruti/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_55"
Java(TM) SE Runtime Environment (build 1.7.0_55-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

=== Xamarin.iOS ===

Version: (Enterprise Edition)
Hash: 8070484
Build date: 2014-06-12 05:06:44-0400

=== Xamarin.Mac ===


=== Build Information ===

Release ID: 501010001
Git revision: 5f2066e8f900f94ed17646f2c32637190addd019
Build date: 2014-06-19 17:11:21-04
Xamarin addins: 4072f200bfd429706bec44bfa9ebf698f9439b67

=== Operating System ===

Mac OS X 10.9.3
Darwin Shrutis-Mac-mini.local 13.2.0 Darwin Kernel Version 13.2.0
    Thu Apr 17 23:03:13 PDT 2014
    root:xnu-2422.100.13~1/RELEASE_X86_64 x86_64

Please let me know If I missed anything to reproduce this issue.
Comment 2 Atsushi Eno 2016-08-08 07:55:36 UTC
marking as NORESPONSE.