Bug 20851 - Failed to load image
Summary: Failed to load image
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 3.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-06-24 13:24 UTC by John Miller [MSFT]
Modified: 2015-09-28 13:00 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description John Miller [MSFT] 2014-06-24 13:24:33 UTC
## Overview: 

    VS fails to load an image select from the iOS Application menu for icons / backgrounds. 

## Steps to Reproduce: 

    1. Create an iOS application.
    2. Go to project Properties page.
    3. Go to iOS Application menu.
    4. Click on an icon or background image holder to browse for an image.
    5. Select an appropriately sized image.

## Actual Results: 

    Image fails to load. Log files show an error message similar to:

Xamarin.VisualStudio.IOS.Widgets.ArtworkButton Error: 0 : [2014-06-20 16:54:19.8]  Failed to load image from "C:Path\to\project\path\to\images\imagename.png"

## Expected Results: 

    Image should load properly.

## Build Date & Platform: 

    VS 2013 and 2012
    XVS 3.0

## Additional Information: 

    I was not able to reproduce this on my environment. User reporting this issue provided a screencast: http://screencast.com/t/2xyHR1jUc and attached log files (private).
Comment 1 John Miller [MSFT] 2014-06-24 13:24:51 UTC
Created attachment 7168 [details]
Comment 2 Udham Singh 2014-06-24 14:25:53 UTC
I have tried to reproduce this issue but not able to reproduce this. To
reproduce this issue I have followed the steps mentioned in bug description and
it is working fine for me.

Screencast : http://www.screencast.com/t/ZmpichZ7

Environment Info :

Windows 8.1
VS 2012
Comment 3 stephen.balhoff 2014-06-24 15:18:39 UTC
I'm the user who originally reported this bug. I have version of XVS. You might have a higher internal build? It tells me I'm updated. While I'm here, I am using Windows 8.1 Enterprise.
Comment 4 Udham Singh 2014-06-25 06:56:08 UTC
I have again tried to reproduce this issue by following the steps mentioned in bug description with xamarin and getting the same behavior as mentioned in comment 2.

Screencast : http://www.screencast.com/t/czE8U9pzIc

Environment Info :

Windows 8.1
VS 2012 and VS 2013
Xamarin.iOS Build Host : and
Comment 5 stephen.balhoff 2014-06-25 11:36:54 UTC
I figured out how to fix it. If the Resources folder is read-only, you can't set the app icons. Even if I check the entire Resources folder out in TFS, I still can't set the app icons. As soon as I right click the folder in Windows Explorer, go to properties, and uncheck "Read-Only", I can open the project properties and set the app icons.
Comment 6 Enzo Heredia 2015-09-28 13:00:16 UTC
not reproducible in Build