Bug 20786 - Android - ViewCell - Entry and non default Keyboard type
Summary: Android - ViewCell - Entry and non default Keyboard type
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.0.6188
Hardware: Other Other
: Normal normal
Target Milestone: 1.3.5
Assignee: Bugzilla
Depends on:
Reported: 2014-06-21 09:33 UTC by daniel.luberda
Modified: 2015-02-18 06:31 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description daniel.luberda 2014-06-21 09:33:42 UTC
When using an Entry in a custom ViewCell with keyboard set to non default value (for example Numeric) - if you focus an entry, default text keyboard is shown then hidden instantly. When you focus it second time, numeric keyboard is shown as intended.
Comment 1 Eric Maupin 2014-07-17 13:35:36 UTC
Made public at the request of the reporter.
Comment 2 Nathan B. Evans 2014-08-11 08:47:02 UTC
I fixed it for now by setting the keyboard into "adjustPan" mode rather than "adjustResize" which appears to be the default.

It seems that any time the ListView is resized, even surreptiously by the OS itself due to the on-screen keyboard appearing, then it causes Xamarin Forms to recreate all the ListView's items (presumably a side affect of how the Adapter was written). This effectively means that the "old" item which had focus no longer actually exists, it has been made into a zombie. So the keyboard enters a bizarre zombie state too where if you type on it, no on-screen control is actually receiving any visible input. The keyboard also loses its InputType if it had one and reverts to a Default mode.

AdjustPan mode seems okay but it does slightly change the keyboard UX a bit, whereby the user can no longer scroll the view for obscured content which is sort of annoying.
Comment 3 Parmendra Kumar 2014-09-01 07:08:43 UTC
I have tried to reproduce this issue and unable to reproduce it.
Could you please provide us the sample project or environment info to reproduce this issue ?.



Environment info:

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641

Xamarin (0b2a123923812a88ed3091909478dbe9e0111f00)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android
Comment 4 daniel.luberda 2014-09-01 07:13:14 UTC
I've looked at your screencast. You didn't change keyboard type to Numeric ...

Keyboard = Keyboard.Numeric,
Comment 5 Parmendra Kumar 2014-09-01 08:20:25 UTC
Hello Daniel,
             I have changed the keyboard type as Keyboard = Keyboard.Numeric on Textbox, After changed these The default keyboard is numeric but after few second it will changed to character.
             Please check the given screencast and please let me me know if I missed anything.

Comment 6 daniel.luberda 2014-09-01 08:23:57 UTC
Hello! Yes, that's exactly the issue I described. It shouldn't change to text keyboard.
Comment 7 Parmendra Kumar 2014-09-01 08:43:13 UTC
As per the comment 6, marking this as confirm.
Comment 8 Brendan Zagaeski (Xamarin Team, assistant) 2014-09-15 03:05:32 UTC
## Closely related bugs
"[Android only] An Entry in a ViewCell loses focus immediately"

"[Android only, certain soft keyboards] EntryCell loses focus while typing"
Comment 9 Jason Smith [MSFT] 2015-02-13 15:45:26 UTC
Should be fixed in 1.3.5-pre1
Comment 10 Ram Chandra 2015-02-18 06:31:38 UTC
I have checked this issue with following builds:


Mac OS X 10.10.0
Xamarin Studio: 5.7.1 (build 17)
Mono 3.12.0 ((detached/a813491)
GTK+ 2.24.23 (Raleigh theme)
Package version: 312000068
Xcode 6.1 (6604)
Build 6A1052d
Xamarin.iOS: (Business Edition)
Xamarin.Android : (Business Edition)
=== Build Information ===
Release ID: 507010017
Git revision: 0bc7d3550b6b088ac25b08dcf7bbe73bcc8658b3
Build date: 2015-02-03 19:43:29-05
Xamarin addins: f7b7d34419c9ec24501bfa7c658e80a6305613e0

Observations: When I click on Entry control in view cell, I observed that  default keyboard always remain numeric it doesn't changes to character keyboard when Keyboard property is set to Keyboard.Numeric

Screencast: http://www.screencast.com/t/W2LDjTGPlYmA

This issue has been fixed. Hence I am closing this issue.