Bug 20741 - Backspace does not work in some menus
Summary: Backspace does not work in some menus
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell ()
Version: 5.0.1
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-19 19:23 UTC by John Miller [MSFT]
Modified: 2016-10-25 15:46 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description John Miller [MSFT] 2014-06-19 19:23:00 UTC
## Overview: 

    The backspace key is not working when editing text in the Properties menu of a control. In the code editor it works fine. 

## Steps to Reproduce: 

    I was not able to reproduce this. Here is a screencast from the user: http://www.screenr.com/csKN

## Build Date & Platform: 

=== Xamarin Studio ===

Version 5.0.1 (build 3)
Installation UUID: cd96c3d5-163e-4cfc-bc30-92c41cb1c862
Runtime:
Microsoft .NET 4.0.30319.34014
GTK+ 2.24.22 (MS-Windows theme)
GTK# 2.12.25

=== Xamarin.Android ===

Version: 4.12.4 (Business Edition)
Android SDK: C:\Users\Steven\AppData\Local\Android\android-sdk
Supported Android versions:
2.1 (API level 7)
2.2 (API level 8)
2.3 (API level 10)
3.1 (API level 12)
3.2 (API level 13)
4.0 (API level 14)
4.0.3 (API level 15)
4.4 (API level 19)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 500010003
Git revision: f94ee866936d25105704eb63728ad5a981eda0a4
Build date: 2014-06-04 12:22:49-04
Xamarin addins: 1a6044e8321ea07e03a56b5381951686c82fed8b

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 1 stevens 2014-06-19 19:28:34 UTC
The issue is not isolated to the properties window. It seems to happen in every window except the editor.

It is possible that I was toying with the key mappings at some point as it does list 'custom' in that settings menu.

I would also note that ctrl+backspace does the right thing.
Comment 2 Sadik Ali 2014-06-20 02:09:18 UTC
I have tried this issue but not able to reproduce it. I have type the text in property window with both physical keyboard and virtual keyboard. Screencast regarding same is below :
Screencast : http://screencast.com/t/dSQt47fK


Environment Info : 
=== Xamarin Studio ===

Version 5.0.1 (build 3)
Installation UUID: 1151d3d9-29c1-4339-b53c-a54856b47901
Runtime:
    Mono 3.4.0 ((no/c3fc3ba)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 304000204

=== Apple Developer Tools ===

Xcode 6.0 (6194.24)
Build 6A216f

=== Xamarin.iOS ===

Version: 7.9.0.272 (Enterprise Edition)
Hash: 0a0102c
Branch: 
Build date: 2014-06-18 22:16:24-0400

=== Xamarin.Android ===

Version: 4.12.4 (Enterprise Edition)
Android SDK: /Users/shruti/Desktop/android-sdk-macosx
    Supported Android versions:
        2.1   (API level 7)
        2.2   (API level 8)
        2.3   (API level 10)
        3.1   (API level 12)
        3.2   (API level 13)
        4.0   (API level 14)
        4.0.3 (API level 15)
        4.1   (API level 16)
        4.2   (API level 17)
        4.3   (API level 18)
        4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_55"
Java(TM) SE Runtime Environment (build 1.7.0_55-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 500010003
Git revision: f94ee866936d25105704eb63728ad5a981eda0a4
Build date: 2014-06-04 12:19:12-04
Xamarin addins: 1a6044e8321ea07e03a56b5381951686c82fed8b

=== Operating System ===

Mac OS X 10.9.3
Darwin Shrutis-Mac-mini.local 13.2.0 Darwin Kernel Version 13.2.0
    Thu Apr 17 23:03:13 PDT 2014
    root:xnu-2422.100.13~1/RELEASE_X86_64 x86_64

Please let me know how I can able to reproduce this issue.
Comment 3 Jason Imison 2016-10-25 15:46:47 UTC
We have not received the requested information. If you are still experiencing this issue with XS 6.1 please provide all the requested information and re-open the bug report. Thanks!