Bug 2066 - monodevelop does not open .csproj files
Summary: monodevelop does not open .csproj files
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8.1
Hardware: PC Mac OS
: Normal enhancement
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
: 2168 5821 ()
Depends on:
Reported: 2011-11-16 16:41 UTC by Sebastien Pouliot
Modified: 2017-07-21 14:37 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Proposed patch (829 bytes, patch)
2012-04-09 07:43 UTC, Rolf Bjarne Kvinge [MSFT]

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Sebastien Pouliot 2011-11-16 16:41:00 UTC
By default MD will open .sln files but does not open .csproj which is annoying.

It's a bit worse when VMware fusion is installed since it will start a VM to get VS.NET to open that .csproj file.

e.g. open attachment from bug #2062, like http://bugzilla.xamarin.com/attachment.cgi?id=898
Comment 1 Rolf Bjarne Kvinge [MSFT] 2011-11-23 08:29:56 UTC
*** Bug 2168 has been marked as a duplicate of this bug. ***
Comment 2 PJ 2012-01-09 11:14:17 UTC
Opening .csproj worked in MonoDevelop 2.8.5 (opened the solution)

Currently, this problem is reoccurring in 2.8.6. 

Opening a csproj files results in only the csproj file being opened. Bug seen on Windows and Mac versions
Comment 3 Mikayla Hutchinson [MSFT] 2012-01-09 13:15:21 UTC
I don't think anything changed in 2.8.6 regarding opening project files. IIRC we never searched for the containing solution when opening a project file, but we did create a temporary solution container.

However, I don't think that's the issue reported here. The issue is that MD does not register itself as a file handler for project files on MacOS, though it's probably not very useful to do so without the aforementioned project handling.
Comment 4 Jeffrey Stedfast 2012-02-15 16:35:16 UTC
lowering priority based on Michael's comment.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2012-04-09 07:43:28 UTC
Created attachment 1635 [details]
Proposed patch

With this patch I can open csproj files both from the command line and when double-clicking on them in Finder.
Comment 6 Mikayla Hutchinson [MSFT] 2012-04-09 10:23:47 UTC
I'm still not sure we should land this unless we also make MD find the containing sln for the csproj.
Comment 7 Mikayla Hutchinson [MSFT] 2012-06-22 12:32:43 UTC
*** Bug 5821 has been marked as a duplicate of this bug. ***
Comment 8 PJ 2013-11-19 16:32:21 UTC
This bug was targeted for a past milestone, moving to the next active milestone.
Comment 9 Amy Burns 2017-07-21 14:37:31 UTC
 I attempted to reproduce this issue based on the bug description with the latest Visual Studio 2017 for Mac Preview version 7.1, and I was unable to hit the problem. If this issue is still occurring for you, please reopen this report and attach a reproduction, ideally starting with a new template project and then adding just the code necessary to demonstrate the issue.