Bug 20540 - XS 5.0 does not recognize Git repository
Summary: XS 5.0 does not recognize Git repository
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: 5.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2014-06-11 16:16 UTC by dj_technohead
Modified: 2014-09-29 13:29 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
IDE log file (26.67 KB, application/octet-stream)
2014-06-11 16:17 UTC, dj_technohead
Details
Ide Log (20.56 KB, application/octet-stream)
2014-06-12 06:51 UTC, Udham Singh
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description dj_technohead 2014-06-11 16:16:56 UTC
XS 5.0 seems to be having issues with recognizing that a solution is associated with a Git repository. I've tried cloning the repository using SourceTree and from within Xamarin Studio.

There are a bunch of exceptions in the IDE log which I've attached.

thanks,
Dennis
Comment 1 dj_technohead 2014-06-11 16:17:22 UTC
Created attachment 7047 [details]
IDE log file
Comment 2 Udham Singh 2014-06-12 06:51:32 UTC
Created attachment 7050 [details]
Ide Log

I have tried to reproduce this issue with the help of bug description and observed that there are a bunch of exceptions in the IDE log but that is not exactly similar to the exceptions which you observed in your IDE log.

Steps to reproduce:

1. Create a simple application.
2. Publish application to the Git repository successfully.
3. Clone the repository successfully.
4. Open the cloned sample, changes the code and then “Review and Commit” this in repository.

After that I checked the IDE log which I have attached.

Could you please provide some steps and other pieces of information, So that we could reproduce/observed the exactly same behavior at our end?

Environment Info :

Mac OS X 10.9.2
Xamarin Studio : 5.0.1 (build 3) 

Build Information:
Release ID: 500010003
Git revision: f94ee866936d25105704eb63728ad5a981eda0a4
Build date: 2014-06-04 12:19:12-04
Xamarin addins: 1a6044e8321ea07e03a56b5381951686c82fed8b
Comment 3 Marius Ungureanu 2014-06-12 07:30:05 UTC
Could you please try enabling the ChangeLog AddIn? It might be the cause of this issue together with a porting over of some configuration from 4.0, I want a confirmation.
Comment 5 dj_technohead 2014-06-12 18:00:35 UTC
Trying checking out this repository: https://teraport@bitbucket.org/teraport/monocross.forms.git from Xamarin Studio. When I make a change to a file and then right click on the file in the solution browser and select "Version Control", the only options are "Add" and "Add to ignore list".

Xamarin Studio
Version 5.0.1 (build 3)
Installation UUID: bfa92f08-b54c-43ca-baac-4c06dda9ee77
Runtime:
	Mono 3.4.0 ((no/c3fc3ba)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 304000204

Apple Developer Tools
Xcode 5.1.1 (5085)
Build 5B1008

Xamarin.iOS
Version: 7.2.3.39 (Business Edition)
Hash: fc6f56b
Branch: 
Build date: 2014-05-19 19:10:29-0400

Xamarin.Android
Version: 4.12.4 (Business Edition)
Android SDK: /Users/dj_technohead/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		1.6   (API level 4)
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

Xamarin.Mac
Xamarin.Mac: Not Installed

Build Information
Release ID: 500010003
Git revision: f94ee866936d25105704eb63728ad5a981eda0a4
Build date: 2014-06-04 12:19:12-04
Xamarin addins: 1a6044e8321ea07e03a56b5381951686c82fed8b

Operating System
Mac OS X 10.9.2
Darwin denniss-mbp 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 6 dj_technohead 2014-06-12 18:14:05 UTC
Hmm... I just tried checking out the repo that I posted above on another laptop and Git is working. So it seems to be environmental.
Comment 7 Marius Ungureanu 2014-09-29 13:29:09 UTC
I've had no repro for this that I could try. (I forgot to comment about trying the monocross repo, it just worked for me.)

I'm closing this, as a WORKSFORME.