Bug 20525 - Updater report msiexec command failed
Summary: Updater report msiexec command failed
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: 3.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-06-11 06:02 UTC by Peter Hultqvist
Modified: 2014-07-02 08:07 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Log from error dialog (40.82 KB, text/plain)
2014-06-11 06:03 UTC, Peter Hultqvist
Install log (151.48 KB, text/plain)
2014-06-13 06:27 UTC, Peter Hultqvist
Screenshot of Error message when uninstalling Xamarin.IOS (5.15 KB, image/png)
2014-06-13 06:27 UTC, Peter Hultqvist

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Peter Hultqvist 2014-06-11 06:02:30 UTC
Current version is Xamarin Studio 4.2.3

Xamarin Update have downloaded Xamarin 3.0 and Xamarin Studio

I click on "Restart and Install Updates".

During the upgrade process the attached error message is presented.
Comment 1 Peter Hultqvist 2014-06-11 06:03:11 UTC
Created attachment 7038 [details]
Log from error dialog
Comment 2 Peter Hultqvist 2014-06-13 05:59:56 UTC
I've tried running the installer and got a dialog asking me to check the Android SDK installation where I found that the build-tools was not installed.
Installing those went fine.

Now the installer only want to install Xamarin 3.0.0.

There are still some issues, will report back after reboot.
Comment 3 Peter Hultqvist 2014-06-13 06:27:04 UTC
The Xamarin 3.0.0 installer failed, attaching install log.

The installer asked me to download
and install it manually.

The installer stops with a dialog saying "'1.0.0' is not a valid short file name."
That is the same error I get when I try to uninstall Xamarin.IOS from the control panel in windows.

I can't upgrade only Android SDK since I either must uninstall Xamarin.IOS(broken) or upgrade it(which requires uninstall that is broken).
Comment 4 Peter Hultqvist 2014-06-13 06:27:20 UTC
Created attachment 7062 [details]
Install log
Comment 5 Peter Hultqvist 2014-06-13 06:27:58 UTC
Created attachment 7063 [details]
Screenshot of Error message when uninstalling Xamarin.IOS
Comment 6 Peter Hultqvist 2014-07-01 05:33:02 UTC
New updates have downloaded but the installation still fails.

I've now uninstalled all but Xamarin.iOS.
The rest was removed by deleting all keys in the windows registry containing the word Xamarin.

Will now install again...
Comment 7 Peter Hultqvist 2014-07-01 05:46:38 UTC
Installation failed, will submit new bug for that.