Bug 20450 - ITMS 9000 Error "Bundle Invalid" from iTunes Connect
Summary: ITMS 9000 Error "Bundle Invalid" from iTunes Connect
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2014-06-06 20:56 UTC by Julian Wyzykowski
Modified: 2014-06-09 09:43 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

App bundle causing error (52 bytes, text/plain)
2014-06-09 09:27 UTC, Julian Wyzykowski

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Julian Wyzykowski 2014-06-06 20:56:14 UTC
When submitting an update to iTunes Connect I get the following error:

"ERROR ITMS-9000: This bundle is invalid. New apps and app updates submitted to the App Store must be built with public (GM) versions of Xcode 5.1.1 or higher and iOS 7 SDK. Do not submit apps built with beta software." 

I am using Xcode 5.1.1 and building for iOS 7. Have submitted updates previously of this app to iTunes without incident. This is the first update using Xamarin Studio 5.0.

Full System Specs:

Mac OSX 10.9.3
Xcode 5.1.1 (Downloaded from the Mac App Store)
iOS 7 SDK, building for iOS 7.1
Xamarin Studio 5.0
Application Loader 2.9.1
Comment 1 Sebastien Pouliot 2014-06-09 08:14:11 UTC
Can you attach* the bundle you tried to submit to Apple ?

* you can mark it private

The build log would also be useful.

Also your version information are incomplete, please complete** them.

** The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).
Comment 4 Julian Wyzykowski 2014-06-09 09:28:32 UTC
Comment on attachment 7016 [details]
App bundle causing error

username: bugzilla
password: kittens123
Comment 6 Sebastien Pouliot 2014-06-09 09:37:25 UTC
The version infromation shows that you are using Xcode 5.1

> Xcode 5.1 (5084)

and not 5.1.1 like mentioned in Apple error message.

>  Xcode 5.1.1 or higher

That should be:

Apple Developer Tools
Xcode 5.1.1 (5085)
Build 5B1008

Can you update to 5.1.1 and try again ?
Comment 7 Julian Wyzykowski 2014-06-09 09:43:31 UTC
That worked. Unknown to me, I had 2 versions of Xcode (5.1 and 5.1.1) and Xamarin must've registered the former instead of the latter. I simply deleted the 5.1 version and now all is well.

Thank you so much for your help, Sebastien!