Bug 20396 - Line Endings setting not respected in auto generated files
Summary: Line Endings setting not respected in auto generated files
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: 5.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Vinicius Jarina
URL:
Depends on:
Blocks:
 
Reported: 2014-06-05 15:46 UTC by John Cachat
Modified: 2016-02-11 21:44 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Cachat 2014-06-05 15:46:22 UTC
I have Line Endings configured to Windows (in Xamarin Studio preferences as well as at the project level).  Every time I open up a storyboard using the new embedded iOS UI designer, every single .designer.cs file in my entire iOS project is touched and the line endings are changed from Windows to Native!  

I use git for source control so it then sees all of these files as changed.  I need to use windows line endings because we have a mix of Mac and Windows developers and have projects that we shared between Xamarin and a VS/Windows web site.

This is using the latest Xamarin Studio (5.0 build 878) and Xamarin.iOS (7.2.3.39) on a Mac.