Bug 20302 - Error MT0000 when deploying to device
Summary: Error MT0000 when deploying to device
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 7.2.3
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2014-06-03 10:54 UTC by Gary
Modified: 2014-06-09 08:15 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Gary 2014-06-03 10:54:56 UTC
This is the first time that I have seen this error after many successful uploads to my phone.  In this case, I accidentally started debugging on the simulator and cancelled out of that, quickly selected my phone as the debug device, and then ran again, so that might have something to do with this error.

Please ensure your device is connected...
Connected to: __phone_____name______
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
MonoTouch.Installation.FailedInstallException: Receive Message Error (error: 0xe800002e)
  at MonoTouch.Installation.InstallationProxyService.LookupApplicationProperty (System.String bundleId, System.String property) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.InstallationProxyService.LookupApplication (System.String bundleId) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer.FindApplication (MonoTouch.Installation.Device d, System.String appId) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer+<LaunchApplication>c__AnonStorey3.<>m__0 (MonoTouch.Installation.Device d) [0x00000] in <filename unknown>:0
Comment 1 Saurabh 2014-06-05 10:07:53 UTC
I have tried to reproduce this issue but unable to reproduce. I am able to debugging the app on simulator and on device just after cancel the debugging from simulator. I am not getting any error.

Could you please provide the test steps/sample project and device information for which you are getting this issue?

Screencast: http://screencast.com/t/R4sXDUTSxWN4

Environment info:
iPhone 4S iOS 7.0.4
iPhone 5C iOS 7.1

=== Xamarin Studio ===

Version 5.0 (build 878)
Installation UUID: 2939b8b4-8977-42bd-82d6-100275ccd9cd
	Mono 3.4.0 ((no/c3fc3ba)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 304000204

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: fc6f56b
Build date: 2014-05-19 19:10:29-0400

=== Xamarin.Android ===

Version: 4.12.4 (Business Edition)
Android SDK: /Users/360_macmini/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 500000878
Git revision: bcd66920d963483e7d638a2339c4022fe035b529
Build date: 2014-05-27 17:36:26-04
Xamarin addins: da9064ce55b0fa90930a7c437a4cc1ae0e5c778c

=== Operating System ===

Mac OS X 10.9.0
Darwin 360-MACMINIs-Mac-mini.local 13.0.0 Darwin Kernel Version 13.0.0
    Thu Sep 19 22:22:27 PDT 2013
    root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64
Comment 2 Gary 2014-06-05 13:36:09 UTC
I tried a few times just now and can't reproduce the error either.  If I see it again, I'll send more information about what I did that time.  I unfortunately can't send a sample project.  I'm using an iPhone 4S with iOS 7.1.1 and am running Xamarin Studio 5.0 build 878.

This error isn't a big problem for me since it's not recurring so in my opinion it could be moved down in priority.  I wouldn't have reported it but the error message asked me to.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2014-06-09 08:15:33 UTC
I'm closing this for now then, please reopen if you run into it again and find out how we can reproduce it.