Bug 20236 - VS 2013 freezes when saving an axml edited in the XML view
Summary: VS 2013 freezes when saving an axml edited in the XML view
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 3.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-05-31 07:04 UTC by Dimitar Dobrev
Modified: 2016-12-22 18:48 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Dimitar Dobrev 2014-05-31 07:04:01 UTC
Steps to reproduce:
1. Open an axml;
2. Go to the XML (as opposed to the designer) view;
3. Make a change;
4. Save without changing the active VS document (that is, stay in the XML view of the axml).

Expected results:
The file is saved.

Actual results:
The file is saved but VS freezes with the "Microsoft Visual Studio is waiting for an internal operation to complete" message.

Happens every time.

Windows 7 64 bit, Visual Studio 2013, Xamarin 4.12.2, 1.12.278, 3.0.54.
Comment 1 Mohit Kheterpal 2014-06-02 10:10:55 UTC
I have tried to reproduce this issue but I am not able to reproduce it.

Steps that I have followed :
1. Create Android project
2. Open .axml file
3. open its source view
4. Make some changes in file and save it via Ctrl+s.

It saves successfully and VS does not freeze as shown in screencast : http://screencast.com/t/bULybgTeo0

Could you please attached test project and IDE logs in which you are getting this issue?
You can get IDE logs via :-> AppData\Local\Xamarin\Log\12.0\devenv.xxx
Comment 2 Bjarke Pedersen 2014-09-26 02:56:04 UTC
I am having the same issue with newest update of 26-09-2014, when editing an axml file and saving vs just hangs - did it get solved?
Comment 3 filip.dusevic 2014-12-01 04:08:30 UTC
Here also. VS 2013, SDK Tools 23.0.2
Comment 4 filip.dusevic 2014-12-01 04:38:32 UTC
Now I tried to work in Xamarin Studio but it appears that it also suffers from the same problem. I experienced this behavior before but deleting bin/obj directories before would be sufficient to remove an issue. Now it doesn't work.
Comment 5 filip.dusevic 2014-12-01 05:15:06 UTC
Xamarin.VisualStudio.ProfilerSettings Verbose: 0 : [2014-12-01 09:46:43.9] BeginEdit
Xamarin.VisualStudio.ProfilerSettings Verbose: 0 : [2014-12-01 09:46:43.9] EndEdit
Xamarin.VisualStudio.ProfilerSettings Information: 0 : [2014-12-01 09:46:43.9] Settings successfully saved.
Xamarin.VisualStudio.TastyPackage Information: 0 : [2014-12-01 09:46:43.9] Hooked up SDB tracing adapter
Xamarin.VisualStudio.TastyPackage Information: 0 : [2014-12-01 09:46:44.0] Initialization finished
Xamarin.VisualStudio.Android.MonoAndroidPackage Warning: 0 : [2014-12-01 09:46:44.0] Initializing Xamarin.VisualStudio.Android.MonoAndroidPackage
Xamarin.VisualStudio.Shell.ShellPackage Information: 0 : [2014-12-01 09:46:44.1] Initial entitlements: Android Business 2015-09-09 17:16:22Z
Xamarin.VisualStudio.Shell.ShellPackage Information: 0 : [2014-12-01 09:46:44.1] Running license sync for Android
Xamarin.VisualStudio.Shell.ShellPackage Information: 0 : [2014-12-01 09:46:46.8] Updated license: Android Business 9.9.2015. 17:16:22
Xamarin.VisualStudio.Shell.ShellPackage Error: 0 : [2014-12-01 09:46:53.5] Background task error
System.NullReferenceException: Object reference not set to an instance of an object.
   at Xamarin.InsightsCore.PlatformServices.<>c__DisplayClass4.<GetDeviceInfoData>b__3()
   at System.Threading.Tasks.Task`1.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()
Xamarin.VisualStudio.ProcessWrapper Verbose: 0 : [2014-12-01 09:46:56.0] -- Starting Process - 12/01/2014 09:46:55 --
Xamarin.VisualStudio.ProcessWrapper Verbose: 0 : [2014-12-01 09:46:56.1] Executable: C:\Users\Filip\AppData\Local\Android\ANDROI~1\tools\android.bat
Xamarin.VisualStudio.ProcessWrapper Verbose: 0 : [2014-12-01 09:46:56.2] Arguments: list avd
Xamarin.VisualStudio.ProcessWrapper Verbose: 0 : [2014-12-01 09:46:56.2] -- Starting Process - 12/01/2014 09:46:56 --
Xamarin.VisualStudio.ProcessWrapper Verbose: 0 : [2014-12-01 09:46:56.3] Executable: C:\Users\Filip\AppData\Local\Android\ANDROI~1\tools\android.bat
Xamarin.VisualStudio.ProcessWrapper Verbose: 0 : [2014-12-01 09:46:56.4] Arguments: list avd
Xamarin.VisualStudio.ProcessWrapper Verbose: 0 : [2014-12-01 09:46:57.8] -- Process Finished [-1] --
Xamarin.VisualStudio.ProcessWrapper Verbose: 0 : [2014-12-01 09:46:57.8] -- Process Finished [-1] --
Comment 6 filip.dusevic 2014-12-01 10:38:21 UTC
Xamarin reinstall solved this problem
Comment 7 joeperkins 2016-04-02 04:04:40 UTC
Same issue plus I loose changes if I attempt to save axml while in designer view, reinstalling Xamarin ineffective. Bug exists on all installs for Visual Studio on different OS and different Android projects. The fact you loose changes should push this up in priorities, saving changes should never result in losing your changes.
Comment 8 e.skonitis 2016-10-05 08:25:18 UTC
I still have this issue. 
Can be reproduced in any project. Even in new created projects.
Comment 9 Jose Gallardo 2016-12-22 18:48:27 UTC
As we've introduced several improvements around axml  support, I'll mark the bug as resolved fixed.
Please feel free to reopen it if you can still reproduce the issue with current bits, adding the following information:

1. Xamarin Logs
Go to the menu "Help - Xamarin - Zip Logs". Please attach that zip file to the bug report.
If you can connect to the Mac, then please run that command being connected to the Mac, that way we'll get the Mac logs as well.
If you cannot connect to the Mac, can you please zip and attach the content of the log files from the Mac located at "~/Library/Logs/Xamarin-4.3/"?.

2. Environment information
Go to the menu "Help - About Microsoft Visual Studio" and press "Copy Info". Please paste that info into a Bugzilla comment.