Bug 19840 - "connect to xamarin.ios build host" window freeze the UI
Summary: "connect to xamarin.ios build host" window freeze the UI
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.12.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-05-16 02:03 UTC by softlion
Modified: 2014-07-10 04:24 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description softlion 2014-05-16 02:03:50 UTC
The mac is previously powered on and build host is running.
Then when i run VS2013 by cliking a project using the "recent project list" of the windows 8 task bar, the "connect to a xamarin build host" sometime appears while the projects are loading, completely freezing the VS UI. No user input can be done anymore in VS. 

The only solution is to kill VS2013, run VS2013 without choosing a project, and when it is fully open use the recent project list from within VS. The "connect..." dialog still pops but don't block the UI.
Comment 1 Tajinder Singh 2014-05-16 03:23:27 UTC
I have checked this issue with the following builds:
VS 2013
XVS 1.12.275

I have tried 4-5 times to reproduce this issue but in my case VS UI doesn't freeze.

Could you please provide logs from the following locations: 

iOS Trace log:C:\Users\User\AppData\Local\Xamarin\Log\MonoTouchVS
For Build Host Log: Location:  Open 'Xamarin.iOS Build Host'->Go to Xamarin.iOS Build Host->View Build Host Log ->mtbserver.log

This will help us efficiently confirm and fix this bug.

Comment 2 softlion 2014-05-16 03:27:16 UTC
Next time the bug appears i'll do that.

It appears only the morning on first start.
Comment 3 Kent Robin 2014-06-30 02:29:57 UTC
This happens to me as well. If I load the iPhone projects in VS2013 it promts me to connect to the iOS build host. As I'm currently working on an Android project and don't have a running OSX host, I hit cancel on the build host and the some of the keyboard user inputs are blocked. When I shut down VS it says something like "a window is blocking the user input, do you still want to shut down?"

My solution was to create a new project without the iOS projects, and it works fine, but it's really annoying to have to do this.

When this occurs it works to write most characters, but a lot of other buttons doesn't work, like backspace, all ctrl shortcuts etc.

Thought maybe it was fixed in the last Xamarin version, but it was not.
Comment 4 softlion 2014-07-10 04:24:15 UTC
fixed in some version