Bug 19630 - Unable to set environment variables for nunit tests
Summary: Unable to set environment variables for nunit tests
Status: NEW
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: 5.0
Hardware: Macintosh Mac OS
: Normal enhancement
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2014-05-08 20:48 UTC by Bruce McLeod
Modified: 2015-03-11 15:34 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 19630 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Bruce McLeod 2014-05-08 20:48:47 UTC
Expected behaviour:

Adding environment variables in the Options > Run > General settings should be propagated to the NUnit tests.

Actual Behaviour:

Adding the environment variables in the Options > Run > General settings does not have the expected behaviour the current work around is to add the environment variables system wide in a launchd.conf file in /etc.

Context:

https://forums.xamarin.com/discussion/15747/setting-mono-iomap-all-environment-variable-for-nunit-tests

Currently to enable the execution of selenium webdriver tests running with firefox on the mac written in C# using monodevelop requires the MONO_IOMAP=all environment variable to be set at a machine level in by creating a launchd.conf file in /etc that contains the following ...

setenv MONO_IOMAP all

MHutch has commented:

 I would advise against setting MONO_IOMAP in your environment as that will affect all Mono programs, and it is itself a workaround that incurs nontrivial overhead.