Bug 19564 - Lazy<T>.Value throws InvalidOperationException instead of original exception when called by second thread
Summary: Lazy<T>.Value throws InvalidOperationException instead of original exception ...
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib ()
Version: 3.4.0
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
Depends on:
Reported: 2014-05-06 12:46 UTC by Matt Ward
Modified: 2014-06-03 13:57 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Unit test for Lazy<T>.Value (825 bytes, application/octet-stream)
2014-05-06 12:46 UTC, Matt Ward

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Matt Ward 2014-05-06 12:46:40 UTC
Created attachment 6744 [details]
Unit test for Lazy<T>.Value

With a valueFactory method that throws an exception, when two threads try to access Lazy<T>.Value at the same time an InvalidOperationException is returned for the second thread and not the original exception.

Tested with: MonoFramework-MDK-

Code which reproduces the problem (unit test is attached):

var goEvent = new AutoResetEvent (false);

var lazy = new Lazy<string> (() => {
	goEvent.Set ();
	Thread.Sleep (2000);
	throw new Exception ("Lazy exception");

Exception firstLazyEx = null;
var thread = new Thread (() => {
	try {
		string value = lazy.Value;
	} catch (Exception ex) {
		firstLazyEx = ex;
thread.Start ();

goEvent.WaitOne ();
Exception secondLazyEx = null;
try {
	string value = lazy.Value;
} catch (Exception ex) {
	secondLazyEx = ex;

Assert.AreEqual ("Lazy exception", secondLazyEx.Message);

The above test succeeds on Windows using Microsoft's .NET Framework 4, but on Mono 3.4.0 we get an InvalidOperationException.

System.InvalidOperationException: The initialization function tries to access Value on this instance   at System.Lazy`1[System.String].InitValue () [0x0012d] in /Volumes/build-root-ramdisk/mono-3.4.0/mcs/class/corlib/System/Lazy.cs:151    at System.Lazy`1[System.String].get_Value () [0x00024] in /Volumes/build-root-ramdisk/mono-3.4.0/mcs/class/corlib/System/Lazy.cs:100    at LazyTests.ThreadedLazyTests.LazyValueCalledBySecondThreadWhilstFirstThreadInLock ()

Looking at the corlib/System/Lazy.cs code a possible fix would be to insert the following code:

lock (monitor) {
    if (inited)
        return value;

    /// New code:
    if (exception != null)
        throw exception;
    /// End new code. 
    if (factory == null)
        throw exception = new InvalidOperationException ("The initialisation..");

Comment 1 Marek Safar 2014-05-07 07:13:07 UTC
Fixed in master
Comment 2 Mohit Kheterpal 2014-06-03 13:57:13 UTC
I have checked this issue and getting same error when I run the attached project as shown in screencast : http://screencast.com/t/RaaI9BDo

Exception Details :
"at System.Lazy`1[System.String].InitValue () [0x0012d] in /Volumes/build-root-ramdisk/mono-3.4.0/mcs/class/corlib/System/Lazy.cs:151 
  at System.Lazy`1[System.String].get_Value () [0x00024] in /Volumes/build-root-ramdisk/mono-3.4.0/mcs/class/corlib/System/Lazy.cs:100 
  at LazyTests.ThreadedLazyTests.LazyValueCalledBySecondThreadWhilstFirstThreadInLock () [0x0005e] in /Users/360logicaxamarinmacmini/Projects/dsfdsfe34434444334/dsfdsfe34434444334/ThreadedLazyTests.cs:34 "

Hence Reopening this issue.

Environment info :
=== Xamarin Studio ===

Version 5.1 (build 327)
Installation UUID: 449f40dd-b3f1-4028-9a6b-cca0d1a2307d
	Mono 3.4.0 ((no/c3fc3ba)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 304000204

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: (Enterprise Edition)
Hash: a82e30c
Build date: 2014-06-02 11:31:47-0400

=== Xamarin.Android ===

Version: 4.14.0 (Enterprise Edition)
Android SDK: /Users/360logicaxamarinmacmini/Desktop/android-sdk-macosx_Róbert_à
	Supported Android versions:
		1.6   (API level 4)
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===


=== Build Information ===

Release ID: 501000327
Git revision: 9a4bf62f59ec39169e4e9b61c3816a03c8ac961f
Build date: 2014-06-03 06:01:06-04
Xamarin addins: b68a34ef2fc4c46b045dc38e26fb199bfe1b201d

=== Operating System ===

Mac OS X 10.8.4
Darwin 360Logicas-Mac-mini.local 12.4.0 Darwin Kernel Version 12.4.0
    Sun Mar 10 18:01:10 PDT 2013
    root:xnu-2050.24.6~1/RELEASE_X86_64 x86_64