Bug 19104 - XAM210: iOS Labs cannot be deployed from Visual Studio
Summary: XAM210: iOS Labs cannot be deployed from Visual Studio
Alias: None
Product: Documentation
Classification: Xamarin
Component: Xamarin University Content ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Adam Patridge [MSFT]
Depends on:
Reported: 2014-04-17 03:28 UTC by René Ruppert
Modified: 2014-06-17 00:04 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description René Ruppert 2014-04-17 03:28:08 UTC
I can perfectly run and deploy the iOS Labs from XAM210 in Xamarin Studio. However on VS I get a deployment error (no further information, it just fails).
I tried to migrate all the source files into a new project and as soon as I add the info.plist the same thing happens to the new project. I compared everything but cannot find any differences. I'm out of ideas. :-(
Comment 1 Adam Patridge [MSFT] 2014-04-17 23:43:45 UTC
I wasn't able to confirm that issue, but I did have trouble with Demo1. One comment I've seen before from a similar failure was to make sure the Mac Build Host is running before launching Visual Studio.

I just grabbed the latest lab code and updated all the Windows Xamarin items in the Stable channel. First, I just hit F5 and it complained about needing to be deployed first. As it suggested in the error, I went into the Solution properties. Inside Configuration properties, I set all the projects to "Deploy". After that it almost worked out.

While I could debug Demo2 and Demo3 on the Simulator, Demo1 fails with "(500) Internal Server Error". That seems to pop up in other bugs and forum posts, but I've never seen it inconsistent within the same solution like that.
Comment 2 René Ruppert 2014-04-18 02:37:41 UTC
Very strange. I also set the "Deploy" flag of course. Still it just fails without and further information. All other iOS projects/solutions work fine.

I have VS2013 with Update 2 (RC) and the latest Xamarin software from the alpha channel.
Comment 3 René Ruppert 2014-05-02 04:29:55 UTC
Currently running class XAM140. A student is using VS2013 Update 2 and cannot build/deploy Lab02 iOS Begin solution. It fails without any obvious error. Same as for me in XAM210. Adding/creating a NEW iOS project works. Something is fishy about the info.plist files with these solutions.
Comment 4 René Ruppert 2014-05-02 04:31:06 UTC
Maybe this should be move from XamU documentation to the VS plugin team as it seems to be related to parsing info.plist in some form.
Comment 5 Enrico Gebauer 2014-05-06 05:58:12 UTC
I can confirm that this seems to be a problem with info.plist. I had the same issue and as soon as I copied the info.plist content from a freshly created iOS project (with VS 2013) to the project from the University lab, it works without any trouble.
Comment 6 Adam Patridge [MSFT] 2014-06-17 00:04:31 UTC
Looks like the root cause here is a combination of a bad .csproj file and mixed letter case between an Info.plist reference and the actual filename.

While there wasn't any decent wording in the error message when this bug was filed, under the current VS beta channel (haven't tested it in stable), there was an error with project referencing both Icon-72.png and icon-72.png. Sure enough, it is in there under both upper- and lower-case "I". As well, while the projects are all restricted to iPhone/iPod, the Info.plist also lists iPad icons (like the Icon-72.png in question). I'm guessing this combination is what causes issues in Visual Studio. Simply generating a new Info.plist would likely exclude that Icon-72.png file and fix the issue, but if someone ever tried to add iPad support to the lab, it would return.

For simplicity, I fixed the project reference duplicate and removed the iPad icon entries in Info.plist.

@René, can you give the XAM210 iOS lab a shot from this branch to see if it is working for you, too?