Bug 19081 - Double.parse problem in armel (soft float) processor [Mono]
Summary: Double.parse problem in armel (soft float) processor [Mono]
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: 2.10.x
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-04-16 07:56 UTC by geral
Modified: 2017-07-12 22:41 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description geral 2014-04-16 07:56:27 UTC
I am using mono 2.10.8, and have problems parsing string to float, double or decimal.
Whenever I do that operation, the decimal separators are ignored.
The pc is running ubuntu linaro, kernel 3.0.35 in a amrv7l processor.
The mono -V as the output:

TLS: 		thread
SIGSEGV:	normal
Notifications:	epoll
Architecture:	armel, soft-float
Disabled:	none
Misc:		softdebug
LLVM:		Suported, not enabled
GC:		Included Boehm (with typed GC and Parallel Mark)

I used a little application to test the number parsing:

double numD = 1.23;
            Console.WriteLine("numD: " + numD);

            string numS = numD.ToString();
            Console.WriteLine("numS: " + numS);

                double numD2 = Double.Parse(numS);
                Console.WriteLine("numD2: " + numD2);
            catch(Exception e)
                Console.WriteLine("Error: "+e.Message);

            double numD3 = Double.Parse("1.23");
            Console.WriteLine("numD3: " + numD3);


The application output is:

numD: 1,23
numS: 1,23
Error; Input string was not in the correct format
numD3: 123

I have tried with decimal, float and decimal, it has the same output.
If i run the application in a x86 processor it has no problems.

Is the problem corrected in the last mono version?
Is it possible to overcome the problem changing mono configurations to 
soft floating point?
Comment 1 Rodrigo Kumpera 2014-05-21 01:18:05 UTC
Please try with mono 3.4.0. Mono 2.10 is no longer supported.
Comment 2 Ludovic Henry 2017-07-12 22:41:27 UTC

I can't reproduce with following version of Mono:

> Mono JIT compiler version 4.6.2 (Stable Tue Jan  3 12:15:30 UTC 2017)
> Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
> 	TLS:           __thread
> 	SIGSEGV:       normal
> 	Notifications: epoll
> 	Architecture:  armel,vfp+fallback
> 	Disabled:      none
> 	Misc:          softdebug
> 	LLVM:          supported, not enabled.
> 	GC:            sgen

Marking as resolved.

Thank you.