Bug 18888 - ios Simulator sometimes doesn't start correctly
Summary: ios Simulator sometimes doesn't start correctly
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.12.x
Hardware: PC Windows
: Normal normal
Target Milestone: 4.0.0 (C6)
Assignee: Bugzilla
Depends on:
Reported: 2014-04-09 07:07 UTC by curtis.harrison@wavetronix.com
Modified: 2015-09-24 08:36 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description curtis.harrison@wavetronix.com 2014-04-09 07:07:55 UTC
It seems like quite often I need to start, stop, and then start my debug session from Visual Studio 2013 to get the simulator to run my app on the Mac Build host.

Sometimes, the simulator disconnects from the debug session of Visual Studio.  When that happens, and I click the 'Start' button in Visual Studio 2013, the simulator will go to a black screen and just hang there.  When I get into that state, I need to click the 'Stop' button in Visual Studio 2013 and then click the 'Start' button again.  Usually, the second time around, the simulator will begin running my app.

Please let me know when this is fixed.
Comment 1 Akhilesh kumar 2014-05-02 10:30:24 UTC
I have tried to reproduce this issue with following builds

VS 2013
iOS for VS 1.12.275

I am not able to reproduce this Issue I have run application 4-5 times on iOS Simulator using VS.

@Curtis, Could you please try it again and provide exact builds version on which you are getting this error?
Comment 2 curtis.harrison@wavetronix.com 2014-05-19 11:57:32 UTC
I am getting this problem on the current version of Xamarin and the iOS Plugin.  I run the update every few days just in case an update has happened.  I am not on alpha or beta, so whatever version you currently have in release is the one I'm using.

This bug causes me to waste about 4 minutes every time I recompile and re-run my app.  This is eating up TONS of my time.

Are the Alpha and Beta builds safe to use?  Is there somewhere that lists what bugs are fixed in those builds?

Comment 3 Enzo Heredia 2015-06-30 14:10:33 UTC
not reproducible in XMA