Bug 18862 - Addin load failure causes XS to crash
Summary: Addin load failure causes XS to crash
Status: NEW
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Add-ins ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2014-04-08 11:45 UTC by Mikayla Hutchinson [MSFT]
Modified: 2014-08-12 21:14 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 18862 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Mikayla Hutchinson [MSFT] 2014-04-08 11:45:11 UTC
When XS fails to start, re-scans addins, and tries again, it fails.

ERROR [2014-04-08 11:43:02Z]: Xamarin Studio failed to start. Some of the assemblies required to run Xamarin Studio (for example gtk-sharp)may not be properly installed in the GAC.
System.InvalidOperationException: The main synchronization context has already been set
  at MonoDevelop.Core.Runtime.set_MainSynchronizationContext (System.Threading.SynchronizationContext value) [0x00022] in /Users/michael/Mono/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core/Runtime.cs:288 
  at MonoDevelop.Ide.IdeStartup.Run (MonoDevelop.Ide.MonoDevelopOptions options) [0x001dc] in /Users/michael/Mono/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:130 
  at MonoDevelop.Ide.IdeStartup.Main (System.String[] args, MonoDevelop.Ide.Extensions.IdeCustomizer customizer) [0x0008d] in /Users/michael/Mono/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/IdeStartup.cs:620
Comment 1 Prashant manu 2014-05-02 07:19:12 UTC
Hi Michael,

We have tried to check this issue but not sure of the exact steps. Could you please provide us some suggestions/directions so that we can reproduce and check this issue at our end?

Thanks
Comment 2 Mikayla Hutchinson [MSFT] 2014-05-05 17:26:10 UTC
This is an internal error that is difficult to reproduce without corrupting the addin database or installing a broken addin.