Bug 18644 - cant see text in editor
Summary: cant see text in editor
Status: RESOLVED DOWNSTREAM
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.12
Hardware: PC Linux
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-03-29 12:26 UTC by glenford.williams
Modified: 2014-04-01 15:18 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
picture showing the error explained (87.84 KB, image/png)
2014-03-29 12:31 UTC, glenford.williams
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DOWNSTREAM

Description glenford.williams 2014-03-29 12:26:24 UTC
on starting monodevelop text editor i cant see the text in the editor only monodevelops' grayish blue background color and even though moving my mouse over the editor i get code highlights and hints...searching around google i was able to find a hack that that seem to fix this issue. export OXYGEN_DISABLE_INNER_SHADOWS_HACK=1


######################
Distributor ID:	Ubuntu
Description:	Ubuntu Trusty Tahr (development branch)
Release:	14.04
Codename:	trusty
###################################################
kernel info

Linux kingwill-desktop 3.13.0-19-generic #40-Ubuntu SMP Mon Mar 24 02:36:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

running gnome 3.10
Comment 1 glenford.williams 2014-03-29 12:31:01 UTC
Created attachment 6435 [details]
picture showing the error explained
Comment 2 Mikayla Hutchinson [MSFT] 2014-04-01 15:18:15 UTC
This is a bug in the Oxygen GTK theme, not in MD.
 
However, more recent version of MD set that environment variable in the launch script to work around this issue: https://github.com/mono/monodevelop/commit/ba9cbb807935707d732a218d389d2a5b0ee2a0a5